Moonlite temperature probe

My people

I have installed SGPro/platesolve 2 and i could not be happier. I have ran my very first autofocus routine last night and it was a blast. The only glitch that i have right now is that it is not reading the temperature probe attached to my V2 mini controller. Any suggestions?


Nothing? nobody is using the moonlite mini v2 and a temperature probe??? i see that in the help file on version of SGPro it says that the input will be ignored if the focuser has a temrature sensor, this is the reason why i am asking. Maybe somebody knows a trick to make this work.

I have a Moonlite v2 mini with the separate temperature probe and have no problems. I’ve never had to do anything with it to get it to work. the v2 mini also has a temperature probe inside the box. Try removing the outside probe, connect the focuser to SGP and see if the temperature shows up.

I have tried your suggestion just now and plugged in just the box and made sure it was connected properly to SGPro. The driver light does turn green and motor position is displayed properly. There is no temperature reading, however, with or without the probe attached.

The next thing I would try is to download the moonlite focus controller
software from and see if the temperature reads correctly in
that software. If it doesn’t then I would contact Moonlite directly.


Thanks for your time. I have spoken with Ron of Moonlite and made sure i ran the non-ascom driver to see the temperature displayed properly and the commands being sent correctly.

So did the temp display properly in the Moonlite software?

yes it does and you can see the commands being sent as well


Sorry then, I have no idea why the temp wouldn’t be read in SGP. Like I
said I’ve never had a problem with mine right out of the box, no
configuration. Can you find which version of the Moonlite Ascom driver you
are using, in the Windows control panel/programs list?

Finally found it. when you go the menu Control panel > Focus > Other > Use TEMPer device for temperature input and make sure this is not checked. I am not sure how this happened but it is resolved now. Thanks for yours help and hope this helps someone else.