Multiple Connection Issues

Hi guys, I am in the process of updating my observatory PC, and Im having issues connecting a few things. I WAS running windows XP with SGP v2.something, and an older version of The SkyX.

I am now using Windows 10, the latest version of, SGP and The SkyX 10.5.0

This is my equipment profile:

Software Bisque PMX
SBIG Stt-8300M with the self guiding filter head FW8

I have basically “cloned” all application installs on the Windows 10 machine, so I have:

TSX 10.5.0
ASCOM 2XMount adapter
SBIG drivers
SGP API Guider

I have copied the settings of the XP machine to the Windows 10 machine also. The camera connects, but not the filter wheel. I have chosen CFW10, as that is what I had previously, and I recall having to set it to that for some reason, either way, no option works.

Second issue, I open TSX, connect the mount, then in SGP I get the error message saying that TSX is not configured for scripting. PHD 2 gives me the same error. I have read a bit on this forum and seen that I need to enable TCP server, which I have, but still getting the same error…
Any ideas?



I don’t have any ready answers for you, but if you attempt to connect the CFW and post the logs, there may be a clue in there.

As for TSX, while SGPro is presenting the error, It is generated by TSX. You may have better luck on the Bisque forums. Make sure that you are not running applications with mixed credentials (like if TSX is running as admin and SGPro is not, bad things will happen)

Thanks for you reply Ken. I have posted in the SN forum. How do I create a log file regarding the CFW?


I posted the link in my reply above

Thanks Ken, I must have missed that…I have attached a link to dropbox with my log file.

Firstly though, a bit of progress. I got a response from the SB forum regarding the mount issue. I ran TSX as administrator, switched on TCP server, exited, ran TSX as normal, and now SGP and PHD2 both connect to the mount.

The filter wheel however is still giving me grief. I can connect to the camera in CCDOps, and the filterwheel works, but in SGP no matter if I choose “auto detect, CFW10, FW 8300” there is no list of filters to choose from…



There are no errors shown in the log, but they do look incomplete. Can describe exactly what you see after you click the “Connect” button for the CFW? Typically, if there is a failure to connect to gear SGPro will pop up a dialog box and say something like “Error connecting to filter wheel. [reason why]”.

Hi Ken. Absolutely nothing happens…it appears to connect. The connection icon illuminates, but the filter selection options are not available. I don’t receive an error message.


Not for nothin… but did you define your filters? SGPro does not have any way yo query SBIG for your filters so the filter list will stay blank until you add them. This is typically done in an equipment profile, but can be done directly in the sequence.

Ohhh, that was it! thought it might be something simple…Problem solved!