New Pegasus Focus Cube only goes from 934465 to 999999

So I have a new Pegasus Focus Cube and in SGP it will not go from 0 to 65534.
It starts at 934465 and goes to 999999.

In Sharpcap it will start at 0 and in the Focus Cube applet it will start at 0 and max out at 65534

Attached is my ascom focus setup which shows what I need to do in order for it to work in SGP.
This appears to be an SGP bug, to me.

Edit: I am on the new beta version 170 but also rolled back to last release and tried that version. Got same results.



Hi @JohnB

I am unable to tell what is going on from the screenshot. Please see here:

Before you send logs, connect to your focuser and attempt to move it from within SGPro.

Certainly possible, but unlikely given the maturity of the code you are referencing. SGPro’s operation of a focuser is pretty simplistic. In terms of reporting position, we take that straight from the driver and dump it to the screen. Either way, if you provide logs, I can give you some feedback. If I’m wrong, I have zero problem eating my words.

Hi… Any reason you have it starting at 65k ? Even though you need to reverse it. Theres no reason to think you need to start rom a high number and go backwards.

A friend of mine setup his and was trying to do something similar but had things confused. I think you should uncheck that.

Also do you get any warning after clicking OK in the pegasus driver configuration with such a large number as start position? I rember at the time there seemed to be a limit to 32k in their condiguration further xpnfusing things.

In any case its best to try to set the focuser to its zero position then tighten the coupler. Once you do that then rack the focuser out in SGP.

Ps. Make sure you dont have a double reverse set… One in pegasus and one in SGPs settings… That causes confusion too. Set the reverse in the pegasus but leave SGPs normal. Try that as well.

I did have a double reverse set.
Good call.
I had reverse on in SGP for the old focuser that I took off and I forgot all about that setting in SGP.
I was using the reverse setting in ASCOM to get it to I guess you could say double reverse.
Anyway, Evangelos from Pegasus remoted in to my computer and figured it out.

If I literally drove it down to 0 in SGP it would read 999999 in the Pegasus Focus Controller and in Sharpcap.
If I set it to zero in either SGP via the Ascom dialog or via the Pegasus controller it would read 999999 in SGP but read correctly in Sharpcap or the Pegasus standalone controller.

Needless to say. I was baffled.


Yep, two of my friends had the double reverse thingy… Glad it’s resolved.

Hi JohnB,

Great to see the problem solved.

Although I’m a little late in coming into this post I would like to add more information for others who may encounter some problems.

The ‘Pegasus Focuser Driver’ is their Native Driver and the driver that should be set up first, not to critical, but may solves problems down the track of confusion.


Connect power USB etc.

Start up the Pegasus Native driver.

Select settings.


Name: What ever you like.

Device: The connection to you computer.

Preset Steps: Leave as is unless you have a need to change them.

Temp Sensor C/F: What ever suits.


Max Speed (Presets)

Pegasus Motor (Accurate) The motor turns at a very slow pace taking longer to move in or out.

Pegasus Motor (Faster) The motor turns at a faster pace less time taken for same distance less accurate.

Custom You have the choice of setting the MAX speed for your focuser movement.

Value: Set Value of your choice. I have custom set mine to "250".

Set: This information is programmed into the Controller Hub EEprom Memory.

This will become your default speed.

New Position: (Reset Motor Position)

This is the most important Option to set the "0" position of your focuser. Use the motor control knob on the hub and move the focuser in as far as it will go or to a position that you feel is safe to prevent damaged if using a Rack & Pinion Focuser. You do not want to drive hard to either end of the focuser as this can cause damage. The Crayford does not suffer from the same problem as the focuser will slip. However, it would be wise to give it some free play as well.

Example : Use the motor control knob on the hub moving the focuser inwards until it is about 10mm from the end this would be number “1” position on my focuser. My telescope Esprit120 has a Rack & Pinion Focuser so care needs to be taken when setting up. Type in “0” then select ‘Set’. This information will be programmed into the Controller Hub EEprom Memory.

Reverse Direction :

Depending on how your Pegasus Focuser has been attached to your telescope will determine whether a forward movement moves your focuser inwards or outwards. Select this option if your focuser is moving in the wrong direction to what you would be expecting.

Limit Position: ON/OFF

Turn on the ‘limit Position’. The purpose is to prevent the focuser from going past the Min and Max position set. Therefore, will not go less “0” or will not go past the Max set.

Min :

You would normally set this to "0".


This would be set to the Max amount you want your focuser to come out. In my case I have a Maximum of "28500", so I have set mine to "27000". Giving me a safety margin of "1500" steps before the focuser would hit the end of travel.

Backlash Compensation: - Steps: " ".

This value can be left at ‘0’ unless you feel you are experiencing backlash. I have measured that there is about 90 to 100 steps of backlash combined in my Pegasus focuser and focuser Rack, so I have set mine to 90.

Rotary Encoder: - Enable Knob: ON

This is personal preference whether you have this on or not. It just means if you wish to alter the focus manually at the Focus Hub then this option needs to be ‘ON’. Other wise it will have no effect.


Other then the Focuser ‘Reset Motor Position’ “0” all other settings need to be entered into your Ascom Driver.

The reason you got a figure of”934465” was due to the value set in the ’Start from Position’ “65534”.

The option, ‘Start from Position’, can be a bit confusing in the Ascom driver, it allows you to set a new focuser position value. If the focuser is at position “0” and you enter “25000” this would then be the new value for that position. Leave it ‘un-selected’ and “0” as the value.

Hi Robin,

That is a great write up and the detailed information that you provided is not documented anywhere on the Pegasus site, that I am aware of.

I have to disagree with your analysis at the very end. The problem that I was having appears to be an issue where the Pegasus Focus Cube does not play well with the reverse setting in SGP, itself. And the fact that I set reverse on in ASCOM and also set the start to 65534 was my way of making the focuser actually work. Although it would drive from 934465 (starting point) towards 999999 in order to work.

Setting reverse on in SGP itself, for some reason that the engineers and programmers of SGP and the Focus Cube driver will possibly have to figure out, causes the Focus Cube or atleast my Focus Cube to register a value of 999999.

When I replaced the original focuser with the Focus Cube, I forgot that I had enabled the reverse direction setting in SGP in order to make that original focuser drive in the correct direction. Actually, I forgot that there even was a setting for that in SGP, completely separate from the setting in the ASCOM driver.

So, ignorant of the fact that I had reverse enabled in SGP and wanting to make the Focus Cube work and also realizing that I was dealing with a 16bit value. I set the starting point to 65534 in ASCOM in order to set a starting point for the Focus Cube that would drive it toward 999999 and actually work with the SGP automatic focusing. AND, I also enabled the reverse direction in the ASCOM driver to in effect, un-reverse the direction.

That is what caused the digital readout to always be at a range of 934465 to 999999.