New sequence with profile

I’m having a couple issues but solved one so posting it for information.
First, if I run a sequence, let it complete and try to create a new sequence with profile, selected no to save the current sequence, select the profile I want to use, I would get the following error message.

" Error creating sequence from profile “SS94” . A circular control reference has been made. A control cannot be owned by or parented to itself."

I click ok and the error message goes away. I then try again and the profile I want to use is not listed. I had to close SGP down completely, restart it and connect everything again then I was able to create a new sequence with the needed profile. It wouldn’t have been so bad except I was having, what looks like a driver issues with my camera and it would take about 45 minutes for it to cool to the set temperature. At home, I have been doing some testing for a gain issue (explained below) and now, I’m not getting the error message but after I do a sequence, go to create a new Sequence with profile, and select the profile , the new sequence opens and says " loading target" with the number of circles next to it. It sits there and slowly the circles change color and it will take 3 1/2 to 4 minutes for the events boxes to appear. I haven’t had this issue before but I did notice after an update (3 or 4 updates ago) that it took longer to add a target to a sequence.

Any ideas on what this issue may be? I am running the latest update of SGP 32 bit.

For information purposes: on my last imaging session I noticed that all my images were being taken at 0 gain. Checking the properties in the camera settings it was set at Unity Gain but the actual gain was at 0 (unity gain on my camera should be 90). I changed it back to 90, took an image and it was at 0 gain . After digging around and reading I noticed in the equipment manager that the gain was set to 0 for all the bin modes. I don’t bin my camera and never changed them there, so somehow they got changed. I set them (typed in) “Not Set” for all bin modes and now my images are done at 90 gain. Just wanted to put this in just Incase someone else may see the same issue.

Thank you for any help.