New User and Freeze Ups

I’m using the trial copy of SGP and trying it out with a windows 7 laptop 64 bit… After opening the program and going to the “control panel” under plate solve, if I select the settings button on the right side of the screen, the program hangs and I have to use the task manager to close it.

I also get a hang after loading a .fit from another session and selecting “blind solve” using as the solver.

Thirdly, I have tried to use one of my images from astro-bin to populate the position a scale blocks in the target window but, I can’t seem to get that to work either. The position blocks stay at 00 and the scale block stays at 0 also.

Any suggestions?

Hi Jon and welcome to SGP. Please see the following post on how to ask for help. This will help us identify issues.

Hi jon, i had the same problem with the freezing after clicking settings. It is unique to Windows 7. The dialogue box is opening in the middle of the screen, behind other programs where you can’t get at it without closing SGP. Try moving all window to the sides of the screen before clicking setting, and you will see the pop up window appear in the middle of the screen.


OK so, your saying that the freeze is only because there is a dialogue box that can’t be seen and that needs an input? I will give your recommendation a try and thanks.

In these situations, you can usually get to the hidden dialogue by holding down the alt key and pressing the tab key to cycle through open applications.

Every press of Tab whilst you hold down ALT takes you to an open application.

Hope this helps.

Well, I was ably to get into the “settings” and found the pop up I was missing so, that problem is solved. I saw a tutorial on line that showed how to copy the position and scale data of a plate solved astro-bin image and then paste that in the reference data block in the target settings window but, when I tried it with one of my .PNG files on astro-bin, the RA and DEC and scale did not transpose. How do you do this and can SGP use a .PNG file for this operation or, must it be a .FIT?


You can use any type of image you’d like. FITS files are best because we can expedite the solve prcess by reading FITS header information and auto populating hints. If you use an image format without metadata attached to it, you will be responsible for typing in solve hint data by hand.

OK, that’s what the tutorial showed but, when I copied the data from my image in astrobin, there was no population of position or scale. I hit solve and it said it failed and was going to try a blind solve. Then it froze up.

It might be that the image was not solved by Astrobin… in which case SGPro would not be able to retrieve it. If it was, you can send us the astrobin link and we’ll take a look.

Yes, the image was plate solved in astro. Here’s the link:

Thanks Jon. SGPro did not support (the apparently new) URL… only the URL. I have added support for this in 2.4.2

I am in my trial period. Can I download this newer version to see if I can plate solve my astro-bin images and then use them to populate the SGP plate solver?



Yes, when it is released for public download you are free to download and give it a shot during the trial.

OK, I hope it’s released before my trial is up. In the meantime, The version I have should be able to plate solve any of my .FIT images, is that correct? I have tried with a couple but, again, the position and scale does not populate when I select an image for the reference data box in the target settings. My image subs have all been taken using Nebulosity with a QSI camera.


Should be out in a couple days. In the meantime, you can use the fully qualified address to the same image:

Yes. It’s likely that Nebulosity does not record location information so it’s not there foir us to find.

Well, I just tried to post in to the reference data block in the target settings and it worked?

I would not have thought to put a web address in that block. That’s why I used the “share” address. Thanks for the help. I think I am going to like this program once I get it all figured out.


Not sure I understand the meaning of the “?” at the end of the sentence. Did it work?

We realize that multipurpose text boxes can be confusing. This is why we have tooltips, documentation and prominent text indicating it is allowed (expected):

The video tutorial I saw on how to use Plate Solved Astro-Bin images in the ref box showed the coordinates and scale being copied from the image and pasted in the ref box, not the web address of the image. I will check out the tool tips from now on. Thanks,