Nikon D810A still not working


I tried Beta but D810A is still not working with SGPro.
Now I am able to connect and take an exposure with ‘use bulb mode only’ enabled.
I can hear the camera shutter open and close and the downloading light on the camera flashes on and then off but SGPro is stuck in the downloading state forever.

Here is the log file:

Last few lines of log are

[2015-10-02 10:22:32 PM] [DEBUG] [Camera Thread] Nikon: Setting output to RAW
[2015-10-02 10:22:32 PM] [DEBUG] [Camera Thread] Nikon: Exposure using bulb mode…
[2015-10-02 10:22:33 PM] [DEBUG] [Camera Thread] Nikon: Timer complete, closing shutter with USB
[2015-10-02 10:22:33 PM] [DEBUG] [Camera Thread] Caught exception in USB Bulb capture: [kNkMAIDResult_BulbReleaseBusy] (kNkMAIDCommand_CapStart, 33560, kNkMAIDDataType_GenericPtr, 201452280)


I’m wondering if this is being investigated.
The only thing that I found so far is that the shutter is not even releasing if I remove the memory card.
In that case, the exception on the log is different.
[2015-10-25 12:19:54 AM] [DEBUG] [Camera Thread] Caught exception in USB Bulb capture: [kNkMAIDResult_NoMedia] (kNkMAIDCommand_CapStart, 17, kNkMAIDDataType_Null, 0)

I’m wondering if SGPro is trying to use a memory card and that’s why it is stuck while downloading with a memory card in the camera and the shutter is not releasing without a memory card.

Thank you.

For your reference, Backyard Nikon has an option to select download types: PC, camera, and PC + camera.
I’m wondering that SGPro is always trying to do PC + camera and somehow D810A is handling that option differently?

Thank you for all you assistance (and the data you collected).

We are not currently investigating compatibility with the D810A. We do intend to, we have just not gotten around to borrowing or purchasing one. Trying to fix this over a chat forum is not an exercise we wish to engage in.

Ken, have you considered contacting Nikon to get a testing unit.
I know that Nikon loaned the Backyard Nikon develper a D810A for few weeks to help him to support D810A.

We have, but to no avail.


Are you guys using Nikon SDK C# wrapper for your implementation?

I downloaded the SDK and the opensource C# wrapper today home and I managed to reproduce the exact same symptom on the sample image capture program from the C# wrapper. The camera is stuck on downloading the image.

After studying Nikon SDK sample codes, I managed to fix the issue after trying all day.
(I don’t know how to download the image to the PC though so I’m not 100% sure if it is fixed but the camera is no longer stuck on downloading).

The C# wrapper always throws exception when the SDK returns eNkMAIDResult.kNkMAIDResult_BulbReleaseBusy so it ends up bypassing many codes.
I found that the sample program on the Nikon SDK ignores eNkMAIDResult.kNkMAIDResult_BulbReleaseBusy on handling kNkMAIDCommand_CapStart. eNkMAIDResult.kNkMAIDResult_BulbReleaseBusy is normal while capturing on bulb according to the Nikon SDK document.

I did two things to fix my issue:

  • Ignore eNkMAIDResult.kNkMAIDResult_BulbReleaseBusy and do not throw exception.
  • Add a second delay after issuing eNkMAIDCapability.kNkMAIDCapability_TerminateCapture (I’m not sure why).

Hopefully this information helps you to fix the issue on SGPro.
If you use the C# wrapper, let me know. I will give you more detailed information (like function and file name).