No autoguide graph

I’ve seen this before, but I can’t find my old message about it. I want to say that SGP is looking in the wrong directory for the log, but it will have to wait for tomorrow for me to try…thankfully…it clouded up! Everything was fine until I upgraded to 2.4.1, then I noticed that plain old PHD was no longer a selection for an auto guider, so I downloaded and installed PHD2, which didn’t help. Going back to 2.3.x didn’t help either. I think when I tried PHD2 initially way back when, this happened…seems like deleting the PHD2 directory fixed it, if I’m remembering right.

Note to self: don’t upgrade if it ain’t broke!
When will I learn!


Right… PHD1 is no longer supported. Sounds like your PHD2 logs might be getting written to the wrong place (or at least aplace SGPro does not look for them). For Windows 8.1, 8 and 7, they should be at:


If you are using Vista (then I can’t remember off hand where “home” is). Windows XP is no longer supported.

While I understand the sentiment, I am not a fan. Upgrade often (but early… i.e. not just before the big star party). We add cool new stuff and fix things you may not even know are broken until they happen to you at a very unfortunate time. We rarely introduce new bugs (unless they are around new features).

Thanks for the reply. I am using Vista, it’s an upgrade from my 11 year old
XP laptop to one that is only 6 years old! So, if SGP is looking in the
wrong place, how would I fix that? If I recall correctly, I think I can
simulate this stuff so that I can test it before the weather cooperates!


OK… I gave some bad data here. It’s been a while since I looked at the auto guider interface. The PHD2 guider no longer requires a log to graph data. It gets points for plotting straight from the PHD2 server. So, if you are successfully connected to the server and you are dithering, pausing, resuming, etc, there should be no reason that you can’t get data for the graph.

Last night I noted that the autoguide graph did not come up till I actually started a sequence. I usually calibrate and settle the guiding looking at PHD2 before I start the actual sequence. I was surprised to not see the graph until the sequence started.

Windows 7, Latest of everything.

Fred Klein

I believe that’s expected behavior Fred. I note the same thing that the graph doesn’t show up until I start the sequence.

Actually the graph can appear at any time. In this case, the sequence was the first thing that “needed” a connection to PHD2. Until the connection is established, no graph will be present. If you had stopped the sequence after the initial connection was made, the graph would have continued.