PHD lost calibration post meridian flip

Tonight I ran into a problem with PHD losing the calibration data after a meridian flip. Given the recent changes to PHD/SGP communication I thought it best to post here first.
PHD2 2.5.0dev3

I started PHD separate from SGP and restored calibration data from a previous session. I then started the sequence and everthing ran normally. The auto meridian flip was triggered around 10:05pm and the flip, auto center and resume PHD appeared to complete as normal. However it was obvious to me that the mount was not receiving guide commands.

What I observed was PHD reporting that it was guiding in the lower left corner complete with the green box etc, but there was no reported error in guiding in the bottom info bar and thus no guide commands were being sent to the mount. Not knowing what else to do I stopped the sequence, closed and restarted PHD and restored the calibration data from a previous session and restarted guiding. Same thing, PHD reports guiding but no guide error or commands being sent to the mount.

So then I closed both PHD and SGP and started completely over. After restoring the calibration data again still the same problem, so I re-ran calibration and immediately guiding resumed properly. It seemed obvious to me that somehow the former calibration data was missing or something, and running a new calibration solved the problem.

Here are several logs from both PHD and SGP surrounding the failure (again around 10:05pm).
SGP Logs
PHD Logs


If found the issue – there was a bug introduced in PHD2 2.5.0dev3 related to flipping calibration after the pier flip. I will upload 2.5.0dev4 with a fix and take down dev3.

It should be fine to use dev2 in the meantime.

Sorry for the inconvenience.


PHD2 v2.5.0dev4 is available now at
It is the same as dev3 except it has the fix for the meridian flip calibration problem introduced in dev3. If you installed dev3, please update to 2.5.0dev4.

1 Like

Well that was fast. Thanks Andy.

1 Like