Plate Solve/Centering from mosaic Wizard

Hi all hope things are going well for you all. I have just started to use the framing wizard however I am having great difficulty in getting it centered per the framing wizard. I am only working with the framing aspect of it as of now.
I open wizard search for an Image (M31 example) plate image shows up, I rotate the image, i draw my square/rectangle. click center here redraw rectangle. click create sequence, select replace targets, check auto rotate (have moonlite focuser). select precision centering. click ok. I do remove autoguiding and focusing for the tests.add Lum filter 2 exposures. and click run sequence. and it runs and fails, and it keeps trying via auto recovery but never gets it right.
I have use slew and center all the time and it works WONDERFUL.
First failure is usually due to rotator. Failed: to rotate camera. But the Rotator has already moved to 120 degrees. I am running an older version and upgrading as we speak but wanted to know if I was missing something. I have read the help file a few times and do not feel like I am missing anything but maybe its something someone has seen. I was running I am now installing

Thanks for any help guys…
GREAT SOFTWARE even with the few “issues” (mainly user error)


Please take a look through here and we’ll see what we can find:

Here is the link to the log files, thanks for your help

Ken I did look through the forum and didn’t find anyone with the same type of issue. I have read the help page multiple times. I have in the past used the set camera angle at start up and it has always failed. I have since just not used it until I came across an object that would not fit in the normal framing after a slew and center. I have tried many variations of settings that have been discussed with in the forum to try and fix the issue. With no luck, hence the reason for my post. I don’t mean to sound rude but I do not post questions on forums at the first hint of an issue. As a matter of fact I have already worked with the manufacture of the rotator and the developer of the driver. Mitch felt that back in May when I had the issue the first time it was a rounding issue within your software. Since May I have not used the rotator as it was intended. I had no real need to. All I am trying to say is i don’t just post at the first simple problem I do try and work them out.

Thanks for helping me along to get this fixed.

I also do not mean to sound rude, but I don’t know you from Adam and I have no way know your mannerisms or to tell what you have or have not done to troubleshoot the issue… so you get the boiler plate response, I get logs, then within minutes I can tell you that the issue you reported is already fixed in the latest beta.

No worries at all Ken. Again I am glad I didnt offend you and I am glad that the issue has been resolved. Although it also turns out I am having accuracy issues with the rotator. When it moves great distances it seems that it may lose steps from time to time. Thanks for replying and I look forward to using the software for a long time to come…

Thanks again.

1 Like

The issue here is that it seems pretty common for rotators to completely ignore rotator commands within small distances from the target PA. For instance if you are at a PA of 23.9 and ask to move to 24.0, the command is completely ignored by the rotator and SGPro would fail (because 23.9 is still reported). There is now a “pretty close” rule built in that will allow SGPro to call this good… ± 0.25 deg.

The ASCOM interface has a StepSize property that’s intended to report the minimum change in rotator angle that is possible. In the case of this rotator it’s about 0.01 degrees.

The error seems to be here:

[11/16/2015 9:04:19 PM] [DEBUG] [Telescope Thread] Performing auto center step 3 (rotator)…
[11/16/2015 9:04:19 PM] [DEBUG] [Telescope Thread] Moving rotator to 24.0…
[11/16/2015 9:05:56 PM] [DEBUG] [Telescope Thread] ASCOM Rotator: MoveAbsSync Timeout! GetPosition reports 23.99, trying to move to 24.00…
[11/16/2015 9:05:56 PM] [DEBUG] [Telescope Thread] Rotate failed…

You cannot expect that the position will be reached to an accuracy of less than the rotator step size.


@Chris Thanks for this info. I have added code to the rotator (using StepSize) to be more precise about possible deltas in actual and target PA. If it’s not implemented, we use a default value.