Plate solve fails

I have deleted all and ansvr files and then re-installed them according to the instructions found on this forum. I am attempting to perform only “local server” solves as my normal observatory site has no internet access.They appear to be installed in the correct places and I have installed all index files from 4202 to 4214. I have tried a good image (M001) without hints and a poor image (IC983) with full hints. None of my images are plate solved. I am sure that the problem is a simple configuration issue. Who can help and what can I provide for analysis?


Hi Frank,

Please upload one of the fits images you having trouble with (dropbox, google drive, or similar and send us the link.) Also please tell us the image scale you have set in SGP (Control Panel => Camera tab => Scale (1x1)).


had the same problem… Check the “Other” setting and make sure it is pointed to the correct endpoint…NOT astrometry . net . It should be a bunch of numbers like http: 207. xxx.xx. etc.

Also check your pixel scale and make sure that is accurate.

Hope this helps. I find it a little slower than using the internet but it does work…



1 Like


I thought we had it solved as when I followed your advice and entered an image scale in the camera settings, the very next plate solve attempt was successful. I worked my way through my images and when I got back to the earlier failures, they failed again.

I have uploaded an example to Dropbox:

It is a fairly good image of M001 with an image scale of 2.05.

Would ansvr logs help?



Thanks for the info. I did step 14 correctly. It turns out that many of my images plate solve in as little as 6 seconds, but some fail.


I downloaded your image and tried a solve. It took a little while to ‘Blind Solve’ - after that, the info was there & Elbrus solved it again in a second or two.
So the image is OK - unsure if perhaps your ansver settings are OK or not - mine attached if that is any help.


Thanks for the feedback. I will try adjusting some settings and see what happens.


Hi Frank,

ansvr solved it successfully for me too. I happen to have the same ansvr settings as Kinch (downsample 2, scale error estimate 5).

Make sure you put your image scale (2.05) into the image scale on the camera tab of the SGP control panel if you haven’t done that already.


O.K.! I adjusted my settings to match those of Kinch and Andy (downsample 2, scale error 5) and started through my images. I am getting about a 50% success rate. In watching the ansvr.log I see two recurring errors:

“can’t setup server: Address already in use at /opt/ansvr/ansvr line 1038”


fitsbin.c:467:rend_chunk: Couldn’t find table “kdtree_data_codes” in file “usr/share/astrometry/data/index-4201-13.fits”

It is a mystery to me why some images are solving and others are throwing this failure message. Any suggestions are welcome!



Please give us a link to an image that fails. We will need that to distinguish if it is an issue with your installation or configuration, or with the solver in general.



This image generates a solve failure in 21 seconds with the log error of “couldn’t find kdtree_data_codes”:

I am working on other examples,


This one fails on tomeout at 482 seconds:

No error messages, ansvr still chugging along.


That should read “on timeout”!

And this one solves in 5 seconds:

All are archive images from earlier this year using the same scope setup and capture software. Sa you can see, these last three examples are from three consecutive days and two of the three fail and for different reasons.

I think I have installed too many index files. If I can find their location, I may delete the narrow field index files as I seldom image narrower than 2 degrees wide fov.

Thanks in advance for your efforts.


This may be overkill but this one, binned 2X2 solved in 21 seconds:

and this one failed in 5 seconds:

Once again with the error: fitsbin.c:467:read_chunk: couldn’t find table “kdtree_data_codes” in file “usr/share/astrometry/data/index-4201-13.fits”

Hi Frank,

All three of those that failed on your system solved on my system. I am guessing you have a corrupted index file (this is the first I have heard of this happening).

I would recommend reinstalling your index files. You can delete the index-*.fits files from the folder


then, run the Index Downloader to download them again.

Hope that helps,


Thanks! I’ll do that next.


One interesting thing here your FITS headers don’t seem complete. Here’s the headers from

FITS header number 1 at block number 1.

SIMPLE = T / file does conform to FITS standard
BITPIX = 16 / number of bits per data pixel
NAXIS = 2 / number of data axes
NAXIS1 = 3358 / length of data axis 1
NAXIS2 = 2536 / length of data axis 2
BZERO = 32768 / offset and data range to that of unsigned short
BSCALE = 1 / default scaling factor
CRPIX1 = 1679 / reference spectrum pixel coordinate for axis 1
CRPIX2 = 1268 / reference spectrum pixel coordinate for axis 2
CTYPE1 = ‘RA—DEF’ / standard system and projection
CTYPE2 = ‘DEC–DEF’ / standard system and projection
OBJECT = 'M001 ’ / Object name
DATE-LOC= ‘2015-02-23T23:14:58’ / Local observation date
DATE-OBS= ‘2015-02-24T07:14:58’ / UTC observation date
IMAGETYP= 'LIGHT ’ / Type of frame
CREATOR = ‘Sequence Generator Pro v2.4.0.2740’ / Capture software
INSTRUME= ‘SBIG STT-8300 3 CCD Camera’ / Instrument name
OBSERVER= ‘Frank Headley’ / Observer name
SITENAME= ‘9th Tee Observatory’ / Observatory name
SITEELEV= 3 / Elevation of the imaging site in meters
SITELAT = ‘37d53m44.100s N’ / Latitude of the imaging site in degrees
SITELONG= ‘121d35m53.500s W’ / Longitude of the imaging site in degrees
FOCUSER = ‘Moonlite DRO Focuser Driver’ / Focuser name
FOCPOS = 11362 / Absolute focuser position
FOCTEMP = 11.42 / Focuser temperature
FWHEEL = ‘SBIG Filter Wheel’ / Filter Wheel name
FILTER = 'Lum ’ / Filter name
EXPOSURE= 120 / Exposure time in seconds
CCD-TEMP= -30.03125 / Camera cooler temperature
SET-TEMP= -30.03125 / Camera cooler temperature
XBINNING= 1 / Camera X Bin
CCDXBIN = 1 / Camera X Bin
YBINNING= 1 / Camera Y Bin
CCDYBIN = 1 / Camera Y Bin
XPIXSZ = 5.4 / Pixel Width in microns (after binning)
YPIXSZ = 5.4 / Pixel Height in microns (after binning)
ANGLE = 0 / Image angle
SCALE = 0 / Image scale (arcsec / pixel)**
XPIXSZ = 5.4 / pixel size in microns (with binning)
YPIXSZ = 5.4 / pixel size in microns (with binning)

Data section number 1 beginning at block number 3.
Skipped 5914 blocks of data of size 2880 bytes (17032320 bytes).

End-of-file after 1 HDU in 5916 x 2880-byte blocks (17038080 bytes).

Scale is 0 for some reason and that makes a big difference in solve speed. For instance here’s the solver with no hints:
$time solve-field --downsample 2 --no-plot
log-odds ratio 174.882 (8.92267e+75), 21 match, 0 conflict, 116 distractors, 25 index.
RA,Dec = (83.7551,21.9691), pixel scale 2.04577 arcsec/pix.
Hit/miss: Hit/miss: +±–±-++±-±----++±------±–±--------------±------±----±------±±------±±---------------
Field 1: solved with index index-4210.fits.
Field 1 solved: writing to file ./M001_120sec_1x1_L_frame6.solved to indicate this.
Field center: (RA,Dec) = (83.76, 21.97) deg.
Field center: (RA H:M:S, Dec D:M:S) = (05:35:01.307, +21:58:08.246).
Field size: 1.90806 x 1.44126 degrees
Field rotation angle: up is 73.9093 degrees E of N
Creating new FITS file “./”…

real 4m3.739s
user 3m55.366s
sys 0m6.525s
Which took over 4 minutes, Now we now the pixel resolution is 2.04577 arcsec/pix. Using this command:

$ time solve-field --downsample 2 -L 1.8 -H 2.2 -u arcsecperpix

real 0m27.884s
user 0m27.067s
sys 0m0.518s

we get 27 seconds because the solver can skip all indexes that are not in the correct arcsec per pixel. If you are centering on a FITS image that recorded RA & DEC and you want to solve to the exact same place you get:

time solve-field --downsample 2 -L 1.8 -H 2.2 -u arcsecperpix --ra 83.75 --dec 21.96 --radius 10

real 0m19.483s
user 0m18.941s
sys 0m0.322s

which is 19 seconds.

My own headers from SGPro have

RA = 258.266666666667 / Object Right Ascension in degrees
DEC = 25 / Object Declination in degrees
CRVAL1 = 258.266666666667 / RA at image center in degrees
CRVAL2 = 25 / DEC at image center in degrees
OBJCTRA = ‘17 13 04.000’ / Object Right Ascension in hms
OBJCTDEC= ‘+25 00 00.000’ / Object Declination in degrees
SCALE = 0.762 / Image scale (arcsec / pixel)

With the scale included. I’m not sure how SGPro makes the request to the ANVSR server in Windows but using those techniques plate solving is even faster. Is that an older version of SGPro?

Anybody using this method you can add –crpix-center to the command and it will use the center of the frame as the reported RA/DEC.


Thanks for the analysis. This may be a clue.
What I have done most recently is remove all of the index files from ansvr and reinstalled only index files 4207 to 4219. This has reduced the solve rates by one to two seconds. It has also reduced the failures to solve by one to two seconds.

I created a new profile with camera angle of 75 degrees and scale of 2.05 asp. I get the same results on each of the ten example images. Seven of them fail and three of them succeed. All within six seconds. I am not sure where to go from here. Do you think it would help for me to edit the exif data to show angle and scale. I will check the images that I have success with to see what exif data is present.

Thanks to all for your support!


To all,

I edited the fits header of one of the images that would not solve. The “angle” and the “scale” were numbers with decimal places to 8 or so. I simply rounded them to 75 degrees and 2.05 asp. The resulting solve failed in six seconds. It may be something other than fits header.


BTW: Windows 7 on HP dv6
ansvr 0.15.3