Plate solving hangs on validation frame

Continuing the discussion from ANSVR Sometimes Stuck on Validation Frame:

I am seeing a similar problem using SGP, but am using PlateSolve2 rather than ANSVR, so ANSVR issues or network connection issues are not what is causing it for me. After a fresh start and after connecting my equipment and slewing to a target, I attempt to center on the target. The initial plate solve works, and the mount moves to center the target. The validation frame is acquired, but the plate solver never starts for the validation frame; it just seems to hang there. The only solution I have found is to quit SGP and start over. Usually I’m well centered on the target after the hung validation, so I can run the new session without a new centering operation, but I’d love to solve this problem because among other things it means I can’t perform automated meridian flips.

Here’s a link to one of many log files describing one of these events: The first plate solve, lines 294-332 in the log, was successful, but the second, lines 349-376, just hung so I aborted (I would have waited longer, but having seen this many times I only waited 30 seconds before aborting this time).

I’m doing several unusual things, not all of which will probably show up in the log. I’m using a Meade DSI IIc as my imaging camera via the Nebulosity 4 ASCOM camera driver. Until I saw the “ANSVR Sometimes Stuck on Validation Frame” thread I suspected my issues were because of the camera driver (and that still might be the case). This driver setup has tended to hang every once in a while, but the failure to plate solve a second time (on the validation frame) happens consistently. In addition, I’m running SGP using Windows 10x64 as a virtual machine in VMWare on a MacBook Pro running OS X El Capitan, 10.11.6. Most things just work this way, but obviously not everything. This particular plate solving issue has only happened with and perhaps one or two immediately earlier versions; prior to that I had everything working.


Interesting that you’ve experienced the same as I did with ANSVR. I’ve not tried SGP again so I cannot comment. I’m using SGP and it’s perfect. I will probably upgrade and try it again but I need to sort out my telescope focuser before. Takahashi don’t make good focusers it seems! :stuck_out_tongue:

And maybe I’ll try backing down to to see if that solves my problem. Thanks for the reply!

David, FYI, I think you are seeing the same issue as some of the rest of us as in this thread:

As far as I know, there has not yet been a resolution. I see the issue with and I have not yet tried falling back to, but will before my next imaging session.

  • Shane

Thanks Shane! I plan to try tonight. Looking (not very carefully) at past downloads, I think I probably skipped over that version.

I got from the archive and loaded it. It works perfectly, so apparently the failure to plate solve a second image is something that cropped up after I’m going to stay here for now.

1 Like

It happened to me again last night, on, with Ansvr 0.18. Given how hasn’t failed once though, it’s not Ansvr that’s the issue. Clearly this is the case as well since you don’t use Ansvr and have the same issue.

I’ll be installing SGP again. Hopefully the next release(s) sees this bug fixed. :slight_smile: