Plate Solving looks for wrong file

I upgraded to 2.4 today and fired it up to test plate solving using remote I loaded a saved image that I have solved in the past. I selected my profile, then right clicked on the image and selected “plate solve”.

What I got was a generic failure message. Here is what was in the log:

[3/18/2015 9:06:13 PM] [DEBUG] [Image Plate Solve Thread] Astrometry.NET convertedAstrometry.fits path: C:\Users\M\AppData\Local\SequenceGenerator\Temp\convertedAstometry.fits
[3/18/2015 9:06:13 PM] [DEBUG] [Image Plate Solve Thread] Astrometry.NET - File is too large, resizing
[3/18/2015 9:06:13 PM] [DEBUG] [Image Plate Solve Thread] Astrometry.NET - Saving file
[3/18/2015 9:06:13 PM] [DEBUG] [Image Plate Solve Thread] Astrometry.NET using endpoint:
[3/18/2015 9:06:13 PM] [DEBUG] [Image Plate Solve Thread] Astrometry.NET - Calling Async Solve
[3/18/2015 9:06:13 PM] [DEBUG] [Unknown] Astrometry.NET uploading file: C:\Users\M\AppData\Local\SequenceGenerator\Temp\convertedAstometry.fits
[3/18/2015 9:06:13 PM] [DEBUG] [Unknown] Exception in Astrometry.NET Solver: Could not find file 'C:\Users\M\AppData\Local\SequenceGenerator\Temp\convertedAstometry.fits'.
[3/18/2015 9:06:13 PM] [DEBUG] [Unknown] Astrometry.NET solve done in 0 seconds.
[3/18/2015 9:06:14 PM] [DEBUG] [Image Plate Solve Thread] Astrometry.NET - Solve Completed
[3/18/2015 9:06:14 PM] [DEBUG] [Image Plate Solve Thread] Astrometry.NET - Failed to solve image.
[3/18/2015 9:06:14 PM] [DEBUG] [Image Plate Solve Thread] Blind solve failed, quitting...

I checked in the directory and the file it created is actually named No wonder it could not find the file it is looking for.

Was this caused by me not fully uninstalling 2.3 before installing 2.4 in the same directory? I would rather not lose all my profile settings when upgrading.

I have not yet tried to plate solve directly from the camera, because I don’t want to have to drag all my equipment out until I know I have plate solving working.


I went ahead and did a full reinstall anyhow (profiles are saved in the user settings directory, so no danger of losing them), but still get the exact same error.

Is the image you opened fits or raw?

The image is fits, it was saved from my CCD.

Ok, so maybe there was something wrong with this file I was using. I grabbed a bunch of other fits files from my PC and most of those are actually coming out with proper coordinates when doing blind solve.

Ah, I see the problem now: I am dumb.

I had accidentally clicked on the jpeg file instead of the fits. :slight_smile:

Sorry about that!

No problem. Would you mind posting that JPG though? In theory, SGPro is supposed to convert it and solve.

1 Like

Sure no problem. I never need to solve for jpegs (in fact I am not entirely sure where this one came from or how it was processed, it is a binned image from my ccd, the fits version of this file works totally fine)

A terrible frame of M45 :slight_smile:

1 Like