Plate solving

i got 99% of everything working in SGP only thing left is to get the plate solving eror to go away.
astrometrics/ localhost / Cygwin /ansrv is all in place and seem fine, but when i try to solve M27 i get "invalid parameter."
the log says …

[2014-07-24 14:12:39] [Connect from]
[2014-07-24 14:12:39] POST /api/login HTTP/1.1
[2014-07-24 14:14:19]
[2014-07-24 14:14:19] serve notfound uri =

im using … C:\cygwin\bin\bash.exe -lc “/opt/ansvr-0.13/ansvr -d -e 5 -z 2” … inside “ansrv” shortcut.
the only thiing not installed is Astrotottila???

any ideas… Mitch

Can you post the address that SGPro is pointing to for the Astrometry.NET

sure can…

to be more specific “parameter is not valid”

i included both hints also…

All is well, it just took a few shot downs and installed astrotortilla, and i solved NGC 7000 with all hints, now i will try blind solve again.
thank you Ken…

ANSVR has no reliance on Astrotortilla. However Astrotortilla does install which ANSVR does use.

How did you do the initial install for Cygwin and ANSVR?


1-installed the small version of cygwin.
2- got the link for OPT. dropped it in Cygwin /opt
3- make my shortcuts.
4-went back online and redid Cygwin using the x32 setup.
5-adjusted my ANSRV links.
6-grabed the larger 1.5GIG cygwin (Andys) dropped it on top of C:/Cygwin.
7-ran a few test , failed…
8 - installed astrotortilla, but NOT cygwin, then reran test and solved m81 in 23 sec off of astrobin.
the error was the URL inside ANSRV, it still stalls for a few second but then it takes off.
9- everything is solving right now.
10-changed localhost to SGP) that might have done it.
the above might not be in the proper order but the results were what i expected…
Astrotottilla fails all solves anything… donno why…ANSRV is flawless.

At the moment everything is working great as installed so i kept notes close by for the next time … thank you.

My guess would be that because he grabbed the OPT only version he didn’t have any of the ‘star tables’. That smaller file only contains ANSVR. When he installed AT, it installed all the ‘star tables’ and that fixed his issue.

That’s correct. Last night I was playing with my old laptop trying to figure out how to install but it turns out to be complicated. Eventually I found about that installing Astrotorilla also installs necessary files for Cygwin and The trick about one of the installation steps is it asked you to select the range of index files. At first I let it select default index files. After this was done, then I installed ansvr and followed instructions from another SGP thread. The local solving failed. So I re-installed Astrotortilla and widen the range of index files (I widened too much because it resulted almost 4GB worth of index files!!!) but that solved the problem. Astrotortilla has a PDF document describing how to do the installation and provided a formula to determine the range of index files based on FOV of your camera and focal length of your scope. It was a good instruction. The PDF document is at:

Here is an outline of how I installed it:

  1. Install Cygwin using default settings.
  2. Create “opt” sub-directory under “Cygwin” root directory. It’s needed for installing ansvr later.
  3. Install Astrotortilla ( ). Click on the “Download” button at bottom of screen.
  4. Follow instructions on screen and read PDF document about choosing index files.
  5. Be patient about installing Astrotortilla because it can take a while depending on range of index files you selected.
  6. Download latest ansvr (0.14): . Scroll down and look at Andy’s very last post.
  7. Copy downloaded ansvr file to C;\cygwin\tmp directory.
  8. Following instructions from the link I provided in step #6.

In step #3, it may not be necessary to install Astrotortilla component since SGP is used for plate solving but I included it anyway and it didn’t hurt. There are several components to select including Astrotortilla,, and index files. I selected all because it was a brand new install.

Hope this helps.