Problems with CEM60 and SGP

I have had problems with my CEM60 and SGP. It may be related to how the iOptron ASCOM driver interacts with SGP. I still cannot get the automatic meridian flip to work but that is another thread.

I had a sequence running of the Rosette Nebula which was going along fine for about 1.5 hours. It was still imaging east of the meridian and before the programmed stop time for meridian flip by the mount. According to the log, SGP had finished an image and was polling PHD2 (2.4.0) for settling of the guider however it appears that the mount had stopped or something. Guide settling failed and SGP went into its recovery mode. It then stuck in this mode and never stopped the sequence. I’ve included the PHD2 log, SGP log, screen captures of 2 PHDlab windows showing the events in this dropbox folder:

SGP fail

This has happened a few times and seems to always happen between images or when coming out of a function (focus, plate solve, etc…). I had run some imaging with just PHD2 and BYE earlier and it ran for several hours without problem.

Last night recovery mode seemed to be stuck at a plate solve window when it was attempting to resume the sequence. When I looked at the iOptron ASCOM window this morning it was no longer showing that the mount was moving however the tracking box was checked. If I tried to park or slew the mount with either the iOptron ASCOM driver controls or SGP controls, the mount did not move. I closed the iOptron ASCOM window and restarted it. I was then able to park the mount with SGP.

From the graphs it looks like the mount stopped, however it was physically moving and was pointed west this morning.

Any ideas? Anyone else using SGP with a CEM60? Or possibly an iEQ45 Pro as it uses the same ASCOM driver?
Hopefully I was adequately able to describe the problem.


I found the manual from iOptron web site and searched for “Meridian” and found this on page 29:

“5.4.7. Meridian Treatment This function tells the mount what to do when it tracks past the meridian. There are two options. Telescope Flip will flip the telescope and continuously track the object. Stop Tracking Pos. will stop the mount when it passes the meridian. You can define how far the mount will track pass the meridian before it stops. The maximum traveling distance in northern hemisphere is 15° passing meridian, which equals to 1 hour. It will be 10° in southern hemisphere.”

Did you make any appropriate changes to “Meridian Treatment” to your mount so that it will continue to track past the Meridian before SGP initiate the new slew of same DSO so the mount will flip? I don’t think you want the mount to stop anytime because it will confuse PHD because the mount is no longer tracking. I think the mount should continue to track in order for successful Meridian Flip initiated by SGP. If you already made appropriate changes, then it’s likely iOptron ASCOM driver issue.


I guess I didn’t explain the problem well enough. My problem happened well before the target reached meridian. SGP failed and could not recover. Meanwhile, the mount kept doing what it was supposed to do. It kept tracking until meridian, did the flip itself and kept tracking.

The software didn’t seem to know what the mount was doing. SGP failed when coming out of an autofocus run. The prior image looked fine but it did not start the one after autofocus due to the failure. That is the strange thing, the PHD graph looks like the mount stopped but when I woke up this morning it was pointed west (opposite side where the failure occured). I could not control the mount with any software until I shut down and restarted the iOptron ASCOM interface.

At no point do I ever tell the mount to stop. That is the problem, the software thinks it did or the ASCOM driver hung, or something else that I can’t figure out. When I say stop time, that is the time the first part of the SGP sequence was to end to allow the mount to do the flip. There is then a duplicate target in the sequence which starts after meridian. It never got that far.


Maybe that might be the culprit. You don’t want the mount to flip on it’s own without telling SGP. Try change the Meridian Treatment setting to allow the mount to track at least a few degrees greater than SGP setting. So if you set the SGP to flip one degree after crossing the Meridian, I would set your mount at least two degrees in Meridian Treatment setup. Who knows what the mount is telling ASCOM with your current setting (mount automatically flipping on its own).


Check my other thread about the meridian flip. I have to do it this way because SGP’s flip routine doesn’t currently work with this mount. I think that may be the ASCOM driver not doing something correctly. If SGP flip is enabled, it will always fail to image west of meridian, even if starting a new sequence which is already west. I have merdian flip disabled in SGP. With my AVX it worked every time, not with the CEM60.


I remember the other thread. I guess you are going to have to bug iOptron about their ASCOM driver.


Hi Chris

Have you tried PHD1 to see if with it the issue is still present?



For this issue, I haven’t. Of course SGP 2.4 won’t support that one when it comes out but I’ll try it. Can’t image for a while now due to storms coming in.


Have you attempted to run conform on your driver? I would be interested to know if it passes.


The official ASCOM page states the 3.0 version of the CEM60 driver passed all of the conformance tests:

I’m really interested to see how this results since I’m considering the upgrade to a CEM60 from my current iEQ45.



I would still be interested to see if Chris could run it with his CEM60. Since the driver supports multiple models it’s possible that it was ran against the IEQ45 and worked fine but would fail when ran attached to the CEM60.


I have run the conformance test on the CEM60:
CEM60 Conformance

It reports passing all tests. However, just passing this for basic function does not necessarily mean it is stable under Windows with other software, does it? I think I may be getting a lockup of the ASCOM interface or driver when run in combination with SGP. When just using BYE and PHD with no automation it will run for hours guiding right along.

Anyway, then back to my other issue. If it passes conformance, why won’t it meridian flip with SGP? The AVX worked every time.

To rule out a conflict with other drivers and software, I did a fresh install of Windows 7 Professional with just my imaging software installed. It did not change anything.

Thanks for any advice, it’s greatly appreciated.

Well if I recall your mount successfully flipped and then did one of the following:

  • had streaks in the plate solve image - This indicates to me that you either need to increase the settling time or that the mount reported that it was done slewing when it wasn’t. If the plate solve started shortly after the slew was started then this seams like the mount was reporting that the slew had completed, in which case you’d need iOptron to address that.
  • flipped back during the verification - this indicates that maybe the mount isn’t sure what to do around the meridian or maybe you have some type of “favor east/west” enabled in the driver. Essentially if the position is accessible on either side that the mount will pick one side over the other.

I would recommend watching the flip happen very closely and taking note of what is happening when. Ie, does the verification happen during the flip or after? If the mount flips back when did that happen? Is it during a slew to correct the mount?

I don’t believe there is anything we can do in SGP at this point other than you upping the settling time which may mask the issue of the mount reporting it’s not slewing when it is. SGP can automate flips for lots of mounts including other iOptron models…I’m not sure what’s so different about the CEM60.

Are you running the mount through POTH (looks like not)? How is it connected to PHD (ASCOM or ST4)?


Even with Conform passing there’s all sorts of possibilities for things to go wrong because of the interaction of one thing with another, or edge cases.

For example there’s a problem with pier flip in SGP running a Celestron GEM and StarSense. This is because SGP does a sync as part of its flip process and the sync done in SS messes up the side of pier and subsequent gotos (It’s fine with the NS and NS+ HCs). It’s because the sync is done after the mount has crossed the meridian. If SGP didn’t do a sync it would be fine.

It’s going to be fixed in the SS HC but there may be something similar going on.


I have increased the settling time and that fixed the issue of plate solve restarting before the mount stopped.

I will watch the flip again, it may clear up tonight.

The mount is connected to PHD by ASCOM but I could change to ST4 if that would help. I’ll give it a try.

I know what POTH means but not sure how it applies. In SGP, I choose the iOptron ASCOM driver as the telescope. Will it work using POTH? What does that change? I’m open to all suggestions.

Thanks for the help,

POTH may or may not change things. I was only asking as previous versions of iOptron drivers could not handle multiple simultaneous connections. It could be worth a shot…also if there is logging in the iOptron driver you may want to turn that on to get another point of reference.


Just wondering what you increased it to? I have to do the same on my G11…it takes a little bit to settle in after the slew, about 10 seconds.


I just put it at 30 sec. I’ll try to test some more tonight. I just chose an arbitrary number which should be longer than a flip takes.

v3 of the iOptron driver does allow multiple connections. That’s the one I am using.

I just did a quick test using POTH. Scope control seems to work fine but it doesn’t seem to directly control the mount. It still has to load the iOptron ASCOM interface to control the scope. Is that how it is supposed to work? I’ve not used it before so I don’t know. I’ll try that tonight too.


I did some test runs tonight trying to get SGP to do the meridian flip. I watched it finish an image then take an image for plate solving. SGP then successfully told the mount to flip (I watched it flip). I then got an error message stating that the mount failed to flip and instead of doing a centering action it ended the sequence. I tried this with both the POTH and the iOptron ASCOM driver. Same result. Here is the corresponding part of the log:

[11/27/2014 10:28:26 PM] [DEBUG] [Telescope Thread] SGM_TELESCOPE_SOLVE message complete…
[11/27/2014 10:28:26 PM] [DEBUG] [Pier Flip Thread] Meridian flip: Scope solve complete…
[11/27/2014 10:28:26 PM] [DEBUG] [Pier Flip Thread] Meridian Flip: Solve and Sync was Successful
[11/27/2014 10:28:26 PM] [DEBUG] [Pier Flip Thread] Meridian Flip: Stopping the Auto Guider
[11/27/2014 10:28:26 PM] [DEBUG] [Pier Flip Thread] PHD Advanced: Stop
[11/27/2014 10:28:26 PM] [DEBUG] [Pier Flip Thread] PHDA: Sent command (PHD_STOP)…
[11/27/2014 10:28:26 PM] [DEBUG] [Pier Flip Thread] PHDA: Received (0)…
[11/27/2014 10:28:26 PM] [DEBUG] [Pier Flip Thread] Meridian Flip: Sending Telescope command to execute meridian flip
[11/27/2014 10:28:26 PM] [DEBUG] [Telescope Thread] ASCOM Telescope: Pier side is West
[11/27/2014 10:28:26 PM] [DEBUG] [Telescope Thread] ASCOM Telescope: attempting pier flip using slew
[11/27/2014 10:28:26 PM] [DEBUG] [Telescope Thread] Telescope: Slewing to RA: 2.71196916666667 Dec: 37.8691527777778
[11/27/2014 10:28:41 PM] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
[11/27/2014 10:28:41 PM] [DEBUG] [MF Update Thread] Performing serialize…
[11/27/2014 10:29:20 PM] [DEBUG] [Telescope Thread] Scope has completed slewing
[11/27/2014 10:29:54 PM] [DEBUG] [Pier Flip Thread] Meridian Flip: Telescope command to meridian flip has completed
[11/27/2014 10:29:54 PM] [DEBUG] [Pier Flip Thread] Meridian Flip: Telescope failed to perform meridian flip
[11/27/2014 10:30:09 PM] [DEBUG] [Pier Flip Thread] Meridian Flip: Procedure complete
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] Blocking Pier Flip: Failed to meridian flip, aborting sequence (True)
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] Run event requested sequence abort…
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] Resuming auto guiding (settling)…
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] PHDA resuming…
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] PHDA: Sent command (PHD_GETSTATUS)…
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] PHDA: Received (0)…
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] PHDA pause state is same as request, returning…
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] Checking RunEndOfSequenceEquipmentOptions, force = True
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] In RunEndOfSequenceEquipmentOptions
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] Stopping auto guiding…
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] PHD Advanced: Stop
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] PHDA: Sent command (PHD_STOP)…
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] PHDA: Received (0)…
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] Autoguider (PHD) stopped Successfully
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] Parking telescope…
[11/27/2014 10:30:29 PM] [DEBUG] [Sequence Thread] ASCOM Telescope: Park message received.
[11/27/2014 10:30:55 PM] [DEBUG] [Filter Wheel Thread] Filter Wheel Dispatch loop: Received SGM_TERMINATE…
[11/27/2014 10:30:55 PM] [DEBUG] [Camera Thread] Camera Dispatch loop: Received SGM_TERMINATE…
[11/27/2014 10:30:55 PM] [DEBUG] [TEC Thread] TEC Dispatch loop: Received SGM_TERMINATE…
[11/27/2014 10:30:55 PM] [DEBUG] [Telescope Thread] Telescope Dispatch loop: Received SGM_TERMINATE…
[11/27/2014 10:30:55 PM] [DEBUG] [Focuser Thread] Focuser Dispatch loop: Received SGM_TERMINATE…
[11/27/2014 10:30:55 PM] [DEBUG] [Auto Guider Thread] Auto Guider Dispatch loop: Received SGM_TERMINATE…
[11/27/2014 10:30:55 PM] [DEBUG] [Main Thread] Performing clean up…

It does the flip just fine but doesn’t recognize that it has.

I am trying ST4 guiding to see if that makes a difference with the driver freezing up.


POTH is supposed to connect to the real hardware driver.

One thing that may help is to run with POTH and turn the traffic monitor in POTH on. Then see what happens at the end of the flip when SGP decides that the flip has not been done.
I expect that SGP will send a Get SideOfPier command and expect to get the reply East as an indication that the flip has been done. The question is what does it get?