Question for iEQ45 users with SGP


This question is for iEQ45 users with SGP: are you using succesfully the meridian flip? Which version of the Hand Controller does your mount have?

My iEQ45 is the 8020B version (one of the very first versions of the mount) with the 8006 Hand Controller and it doesn’t handle the meridian flip because the ASCOM driver for that version of the mount wasn’t further developed by iOptron. That version doesn’t allow the Park command either.

Thus, I’m considering either upgrading the mount to a CEM60, or upgrading the boards of the iEQ45 if a newer version is capable of being fully controlled through ASCOM by SGP.

By the way, I’m using the evaluation version of SGP to do some imaging with good success. Will post them soon. The mount seems to handle several objects per night with no problems at all.

Thanks for your help


You may want to look here about the CEM60. Looks like the ASCOM driver has an issue. We’re hopeful of working with iOptron to resolve it though.

Can you upgrade your current firmware or hand controller to bring it up to a standard that will work without having to upgrade your entire mount? Although if you’re looking for an excuse to upgrade your mount then disregard :slight_smile:


Hi Jared

I’d gladly upgrade the firmware of both the Hand Controller and the boards of my iEQ45 but it’s just not possible because first I need to upgrade at least the boards and desireably the Hand Controller also to the 8007 version. That was confirmed by iOptron because my mount happens to be one of the very early ones. The firmware version is 1.05 from 2010.

Something similar happens with the ASCOM driver that was last updated back in October 2011.

So, I’m debating between upgrading the boards and HC, or the mount. Since the 8407 HC is not longer offered with the current model (iEQ45 Pro uses 8407+), I’m afraid something similar to the current situation will occur in the future if I choose to upgrade the HC a and boards.

That’s why the CEM60 seems to be a very good option :grinning:.

I’m following the thread you linked, since once solved the issue, there would be the benefit of a higher payload capacity with an specified smooth tracking (± 5 arcseconds as stated by iOptron) if I want to upgrade my current C925 EdgeHD.

Best regards



I tried this tonight, I have the iEQ45 v2 AZ with the 8407+ handset and running Nov 13 firmware and ASCOM driver 2.4.

Did 3 flips only one of which worked successfully (though manual intervention required).

You set the mount to continue tracking but the hand controller still puts up a message saying meridian reached, enter to flip or back to continue. I hit back the first time and the flip completed successfully.

I then tried without hitting the back button, the flip started ok but failed - further investigation showed that the com ports been disconnected, no mount information was present in SGP or PHD2 - both had to be closed and restarted before I could connect to the mount (or any other USB device) again.

I had seen this before, when the mount goes though a long slew it seems like the ASCOM driver fails in some catastrophic fashion crshing the USB hub in the process. I though this was an issue with my setup and re-jigged everything and have replaced everything, new hub, cables PC (local Intel NUC next to the mount) etc. The only solution was disconnect and reconnect the hub so regain communication.

As the PC is next to the mount I then plugged the USB to Serial converter directly into the PC and ran a sequence again that would result in a flip, did not touch the controller and though it got further is completely locked up SGP which could only be closed by killing in task manager.

I use Windows 8.1 and the both the NUC and the Hub I use are USB3 so this maybe a USB2/USB3 compatibility issue as I suspect I would have seen reports of the problems I am seeing if this was more widespread.

I would look at a mount upgrade against any form of upgrade to you current mount, the CEM60 looks to be a good mount and was what I was going to get before a 2nd hand Paramount MX came up.

There was talk of an upgrade being available for some of the older iEQ45 mounts to the Pro version, this may be an option as will use the new control boards, firmware and ASCOM driver which address a lot of the issues with the previous mounts/ASCOM driver.

I was hoping that the changes made in the CEM60/iEQ45 Pro ASCOM driver would find there way into driver for earlier models, maybe they will in time though reading between the lines the older hardware may not be capable - hope I have read that wrong.


Thanks for the detailed report Trevor.

It seems like the ASCOM driver is still wrong with the 8407 hand controller, so I agree with you: the upgrade of the current iEQ45 to the Pro version, or even the CEM60 should be the way to go to take advantage of the new ASCOM driver.

This has been really helpful.

It would be interesting to know experiences from other users also.

Best regards,