Random slew after plate solve

I have had SGP for over a year now and it mostly works flawlessly. I have had 2 separate times where I would input plate solve coordinates from astrobin and my own images of the target I want to image and would get a populated image location along with the verifying pop up. I would start the sequence and the software and mount will do its thing and when it moves to the location to take its first image to verify its on the target it will download and be right in the center but not within the exact 50px error I have it set to. So normally this is when the mount should attempt to re center it to my settings of 50px but when I can clearly see the first plate solve image and the target in the FOV, the mount will randomly slew to some off the chart location anywhere but specified and wants to slew the scope into the tripod. I have no clue what to even do, I have tried to reset the mount to factory settings, upgrade SGP to the current software version (no beta version). The funny thing is it has only happened to these 2 targets only (so far) The horsehead nebula, and M8 the lagoon nebula. I have used these features for over a year with no problem and its always right on so I don’t know whats wrong. I can plate solve a different image before and after those 2 targets and it does exactly what it should every time. What are some of your thoughts? I will add Ken the awesome guy he is set up my software at a local star party and I haven’t touched any settings since. Thanks, Justin

Are you plate solving very near the pole? This often creates the issues that you’re talking about.

Also if you can attach a log that would be great.


Well I have searched the forums and no one has the same problem. The targets were no where near the pole nor was my plate solving. I would even slew the mount to the target first and start there and no luck. I always wait till they are 20 degrees above the horizon also. I could solve and go to the rosette no problem, No go when I would try near the orion constellation or the lagoon, but it worked flawless going to the trifid nebula. Im going to sound stupid but where and how do I find and attach a log? This software has ran so perfect that I haven’t had any issues ever. Thanks, Justin

You can find it under the “Help” menu in SGP. There will likely be a handful of them in that folder. One is created each time SGP starts. Just find the one that corresponds to when you had this issue. Also if you can let us know a general time when the problem happened that is helpful.


sg_logfile_20160607210123.txt (705.1 KB)

I believe one of the times it starts is 11:40:57

You might see a bunch of weird things in there since I had to get up to turn the mount off to keep it from hitting the mount

Anybody have any ideas what could be going on?
Thanks, Justin

Hm, unfortunately I don’t see anything out of the ordinary. Except that SGP loses connection with your scope about 12 seconds after the slew but I assume this is you pulling power or something to that effect. It also seems that this happens on the first attempt and not on an adjustment of a previous attempt which is actually good as it means things are likely behaving consistently

Maybe try a couple of different things to narrow it down:

  1. Solve and sync manually in SGP and verify where your scope thinks it’s pointing at.
  2. Disable any pointing model in the scope

Other than that I’m not really sure what to try. The Celestron ASCOM driver is generally pretty robust. Turning on the debug log on your telescope and sending that with the SGP log would also be helpful so we can try to see what is going on from the scope side.


Ill try those out then. By no means am I questioning your knowledge just asking a simple question here. If everything seems okay in the logs, when the mount slews to the location and takes the first frame to make sure its in the location and it clearly shows in the frame once it downloads. What is the log saying about it slewing to BFE? I mean it should be logging what its doing when it decides to go off on its own after the frame shows its right where it needs to be right? So there should be something saying why it went elsewhere I assume. Ill try what your suggesting in your above reply but I also don’t know what you mean by both of them. When you say disable any pointing model are you meaning to not align/calibrate my mount when I initially turn it on? What/ how do I solve and manually sync in sgp? Like I said this software has never given me problems and I don’t know what you mean simply because I have never needed to do anything besides copy and paste my platesolve from astrobin and push go.

Thanks, Justin

Nope, because we can only tell the telescope where to go. We can’t force it to do so. We told it where to go and for some reason it decided to go somewhere else. You can see this in your logs:

6/7/2016 11:48:22 PM] [DEBUG] [Telescope Thread] Telescope: Syncing to J2000 RA: 18.2998341603286 Dec: -24.3340194702346
[6/7/2016 11:48:22 PM] [DEBUG] [Telescope Thread] Telescope Sync:  Passed in J2000 but mount requires JNOW, converting... 
[6/7/2016 11:48:22 PM] [DEBUG] [Telescope Thread] Telescope: Syncing to JNOW RA: 18.3169215515441 Dec: -24.3238114497764


[6/7/2016 11:48:23 PM] [DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 18.0627777777778 (18:03:46) Dec: -24.2469444444444 (-24° 14' 49")
[6/7/2016 11:48:23 PM] [DEBUG] [Telescope Thread] Telescope: Slew received J2000 coordinates, mount requires JNOW, converting...
[6/7/2016 11:48:23 PM] [DEBUG] [Telescope Thread] Telescope: Slewing to JNOW RA: 18.0798739876933 Dec: -24.24250922273

(I’m not sure why it decided to make those lines red…disregard the coloring)

So as you can see we synced the mount and then told it to move just a few arcminutes from where it was synced. For whatever reason the mount decided to go someplace completely different. I can’t tell you why. But things I would check in the actual mount settings would be:

  • Bad pointing
  • Bad date/time
  • Bad Lat/Long
  • Incorrect sidereal time
  • Incorrect hemisphere

If you lost power or the little coin cell in your hand controller died it could have reset some things.

Yes, or just do a single star sync. But don’t go through and create a 4 star model or anything like that.

That’s about all you should need to do. It sounds like something has changed with some part of your setup though. And most likely in the actual hardware settings on the mount. That would be my first place to look at least. My G11 w/Gemini behaves in a similar manner and usually I find that the Lat/Long has changed for some reason (generally due to a power outage)


It would be really nice if people were to give some information about their system when they are asking for help. Fundamental things such as what mount, what control system and what version of the various bits of software being used.

You are more likely to get help if you make it easy for people to help.


You make a good point so here it is.

Celestron cge pro mount
Skywatcher esprit 120 ed apo
Atik 383l mono
SGP version
plate solve 2 in SGP
Phd2 2.6.0
Windows 8.1

This information can be added to your avatar settings.

The Celestron Hand control type and version as well please. It makes a difference because the ASCOM driver behaviour varies depending on this.
And the ASCOM driver version of course.

If the Celestron driver is involved in some way then the sort of information I need is described in the driver help document.

This may seem like a lot but it will take a lot less time than an interminable game of 20 questions.