Sequence Generator Pro (BETA) - Testing


I’ve been wanting to try out dual imaging so keen to look at SGPro v4 Beta. I downloaded v4.0.0.668 and have been testing it out. I’m stumbling at the first hurdle - the new Switch support looks like it’s creating an exception that ends up with the sequence aborting “Error - Switch “BlewDew Switch-0” is not connected!”. I’ve attached a log file. There’s also an “Error (reparent)” in the log file.

v4 seems to be scanning for ASCOM Switch devices and assumes I want SGPro to be in control of them. I don’t.

I have two ASCOM Switch devices (both controlled by my own App):

  • BlewSwitch - controls four mains power outlets for different equipment in my obsy
  • BlewDew - controls a four channel dew controller

I can’t see any way to tell SGPro not to try and connect - my App is already connected, so when SGPro attempts to connect as well it gets an exception.

I also use an Optec ASCOM server, so just for fun, I tried attaching the BlewSwitch through the ASCOM server so SGPro could connect to the switch as well as my App. SGPro then discovered the switch through the ASCOM server and directly … again failing when it tried to connect to port ‘COM3’.

To check my sanity I’ve installed SGPro v3.2.0.660 - that runs OK (doesn’t know anything about switches?).


V4 doesn’t currently have anything different than V3 in terms of running multiple instances. We may need to look at how the switches are working in order to allow multiple instances to run. I think this will take some additional work on our end to track down how to best handle the switches with multiple instances.


Thanks Jared.

Is there a configuration control that allows me to select whether or not I want SGPro to connect to a switch - it looked like SGPro searched, found and tried to automatically connect to my ASCOM switches?

No, currently this is automatic which is likely problematic for 2 instances of SGP.