SG Pro Sequencer won't complete tasks or transfer frames

Newb. Been using SG Pro for several week (ver 2) and find it quite buggy. My current problem is when I star a sequence, the event time counts down but the frames are never captured or transferred. The time elapsed passes the time left, and nothing ever happens. I checked the log and found some errors locating what looks to be some bread crumbs in the \users\AppData tree. I’ll try removing the app and forcibly remove all the stuff it leaves behind and try again. Not sure if this is something I missed, but I could not find it in the forums.

In general, SG Pro doesn’t do a great job of handling exceptions, most seem to get routed to the default exception handler. If I do anything even slightly different, I get all sorts of pointer exceptions (programmer didn’t check for a null pointer or didn’t fail the GET that grabbed the NULL pointer), It tends to leave stuck and orphan threads, and often requires reboot if I kill it through task manager. I’m going to stick with it a while longer but so far I’m underwhelmed.

–Steve

Hi Steve

Well it does sound like you are having problems. This is not the norm, I assure you :grinning:.

There is information that you can submit that will help everyone help you, How to ask for help.

A description of your setup - mount, ccd, pc and cabling environment and a step-by-step description of what you do that creates these errors - will all help.

HTH

Of course doh! Celestron CGEM ASCOM, Edge 11" OTA F/10, PHD 22.6.3 guider on QHY5-ll guider and 80mm Orion tube, QHY10 ASCOM binning 1x1 and 4x4 (no difference in behavior). Windows 8.1 Pro. i7-7700, 16GB, 1G SSD, GeForce 1050. Now I’ll go read the instructions on how to post (I always read the instructions last).

–Steve

Not sure if this helps, but in the sequencer, I quickly setup four exposures at 5 seconds each. Elapsed time counted down and five seconds into the sequence up popped a dialog that said the sequence was finished, do I want to run Finish… Nothing was transferred. Total frames complete 0/4. Tried it with 3 for the heck of it. Event 1, Run checked, Type=Light, Filter=None, Suffix=‘rn’, exposure=5s, bin=1, repeat=3. Same thing, finished after the first 5 seconds had expired. Nothing ever appears in the progress bar.

OK, never mind. The log file said SG Pro could not find the sgd files, so I deleted the user and equipment profiles and recreated them, and now it works. It’s still fragile at times, I I do get occasional null pointer exceptions and hangs where I have to force it to die. But at least I can shoot again.

–Steve’

Hi Steve

Some thoughts (you may already be familiar with these points below, so apologies if you are):

Have you followed the help files with the suggested set up for the first few days, http://mainsequencesoftware.com/Support? Or perhaps look at these useful tutorials, http://www.digitalastrophotography.co.uk/Astrophotography/Setup_Videos.html.

You may well have read already about the difficulties that usb cables and hubs can cause? There are QHY users who may be able to give specific advice, ensure you select the QHY ascom driver, update firmware etc.

Are there particular steps that cause the errors and crashes?