SGP 3.1 and Primaluce Eagle 2 and 3

Recently I updated my SGP installed in my Eagle 2 and that led me down a bit of a rabbit hole and thought the solution would be of interest to others.

Overview:

Updating SGP to version 3.1.x requires a .NET version of 4.7 onwards.

As the Eagle 2/3 has a fixed OS with Windows 10 LTSB 2015 installed on the Eagle 2 and LTSB 2016 installed in the Eagle 3 means that SGP 3.1 and other apps requiring .NET 4.7 onwards will fail.

You are unable to install the latest .NET versions as this will fail with an error about incompatible OS - even trying to install the LTSB version of .NET also fails.

After some reading you can install Windows 10 LTSC but this was not straight forward and there was conflicting information as to whether it would do an in place upgrade retaining data and apps (like the important AP-Host mode setups and Eagle Manager etc) plus all your hard work config’ing SGP / PHD2 etc etc!

I read a couple articles how to downgrade (sic!) to Windows 10 Pro as an option to get round LTSB upgrade issues.

And so I set about working out how to do this and found a couple articles on this.

Since writing this I also heard from Primaluce who acknowledge the issue and offered a not so helpful answer to do what I have done here or return it and get them to upgrade it at a cost of post and LTSC licence … 85 USD … not helpful given it was meant to be an IOT device…

So I suggest the following…

Solution:

Firstly - you do this at your own risk OK! I am not responsible for any issues or data loss you encounter!

I have done this on both my Eagle 2 and 3 so I know it works but if you mess it up … you make the mess !

It does require changes to the Registry so be aware you know what you are messing with!!!

What you need:

The registry edits can be found on this video: https://youtu.be/r5GnFru0zas

You also need a copy of the Windows 10 ISO: https://www.microsoft.com/en-gb/software-download/windows10

  • Download it and use the tool to create an ISO file - you can install this temp on the Eagle C drive for now - you can mount this as a drive in the Eagle when you come to do the upgrade by double clicking the ISO file

You will need a licence key for Windows 10 Pro - I bought mine off Ebay from many of the the resellers - they are quite cheap - you only need the licence key - keep it close by when starting the upgrade process

Steps:

  1. Remote desktop into the Eagle - you can reconnect once the upgrade process is done - took mine about an hour.

  2. Use Regedit from the command line and make the changes to the registry in the places shown in the video - make sure you spell it exactly as shown and in the right places!

  3. Double click the ISO and mount it

  4. use file explorer and find the setup.exe - double click it and it will launch the Windows 10 installer.

  5. Follow the installer - I used US English as the language - You want to keep files and apps - very important

  6. Enter the windows key you purchased above

  7. Continue though the install and the installer will install the Windows 10 files needed

  8. At some point the install will kill the RDP session and you will loose remote access - be patient - go have dinner or watch a movie then come back in an hour or so and the install should be done. Watch the activity light on the Eagle and once its done the activity light should be much quieter! (if you have a spare monitor you could plug that in but I didn’t bother and both installs went fine apart from the hour or so wait)

  9. Reconnect to the Eagle via remote desktop and you should be able to log in using the same log in and password on Windows Remote Desktop. All accounts and apps remain in place if you followed the instructions!

SGP will now upgrade to 3.1 successfully as W10 Pro has the latest .NET versions installed

Finally…
Downside is you now have a full version of WE10 Pro on the eagle and that means updates - I disable updates if I am imaging - be warned!

So this gets round the LTSB to LTSC upgrade worries

I suspect a lot cheaper too then sending it to Primalucelab.

I also suspect that as more software uses the latest features of .NET this will become more problematic so liable to have the same issue for Eagle 3’s !

Hope this helps avoid the long reading sessions I did to try avoid this path … oh well!

Cheers

Simon

Hello, I have also migrated to Pro on my Eagle 2. However, I seem to have lost the eagles safe switch of Ising its own created wifi network. I hear the beep when you push on the small button but no more eagle wifi network. Did you run into the same issue ?

I didn’t no

I’ll double check both units tonight

I’d suggest reaching out to Fillipo at PrimaLL as this was the suggested ‘fix’

Cheers

Simon

If you lost the ability to network in you may have done a full install of Win 10 Pro rather than an upgrade. If you overwrite the eagle software then you will no longer be able to remote into the unit unless you restore from a backup or Primaluce would have to reformat your ssd. There should have been an option to keep all files when you installed and that would have let you continue to remote in.

I just changed to Pro last night and had no issues.

Thanks for your hard work.
I just finished upgrading my Eagle 3, worked perfect.
Tim

In fact, my files were untouched so it is a mystery. I’m in contact with Primalucelab for support.

Need help with this. I’ve followed the instructions to the letter above. The problem is that I can’t get passed the screen on update for migrating apps and files as it’s greyed out. This is usually a language issue. I have tried a US install and a UK install. I have set all language features and have done all the trouble shooting steps on this web page


I have payed for a key on eBay as suggested and this wouldn’t work. I found a key on this page https://www.windowsfeed.com/2016/08/windows-10-product-keys-serial-keys.html which worked but only one will work. Feeling pretty exasperated as I’ve been trying to sort this out for 8 hrs straight with no success all so I can access SGP again which now won’t load as it’s asking for .net 4.72 +
What do I try next?

I’ve also tried Primaluce who just say to do the upgrade to Professional.

I suggest you re-read the instructions and ensure all the regedit changes are made and in the right places and the exact spelling - it would seem that the regedit changes are not being recognised

its actually a DOWNGRADE you are performing - with the regedit changes made to the letter and the key you have it will work

I’ve done multiple Eagles with this process and heard now of plenty following the instructions and getting the changes made

but you need to have the exact spelling and the exact entries for windows to recognise the downgrade to professional

recheck the regedit changes I am sure you will find something is missed or misspelt

cheers

Simon

Have made some kind of breakthrough. I installed windows updates which I’ve never done on my Eagle. Got quite a different looking interface when it booted up and ‘professional’ is showing in the system info. I’m now in the process of running the upgrade but it’s downloading updates. I’ll keep you posted. Hope I’m not ruining my Eagle

Right. It’s now working. Anyone else reading this…you need to allow windows to do updates before you attempt it. Still feeling sick to the stomach but will report when it’s complete.

All now working as it should. Not liking the extra interface but SGP is running the latest version and wifi over RDP is stable. Looks like there is work to reconfigure the access point.

Thanks for the head up. I’ve been looking into getting an Eagle 3. I just may be holding off just a bit to see how things progress.