SGP + AP Mach 1 repeatable issue

Tonight while running SGP on my AP Mach 1 system I encountered a repeatable problem.

I"m hopping it’s a simple issue although I could not work through it. Last night, I had ZERO issues but tonight anytime I would slew the mount from inside SGP it would stop tracking. Is this a common issue or have I done something inside the control panel?

Thanks in advance for steering me in the right direction!

First Post! Woot!


Are you referring to the nudge arrows?


I backed out of the AP ASCOM tool and tried from there as well, but had no luck. After resuming from park at the hand controller, enabling a sequence stops tracking on the mount.

I’m not really sure. From your desription, it’s difficult to determine what is happening. Please see this post (also, the AP ASCOM logs would be helpful):

I believe I experienced the same thing. I always slew to a known star nearest target DSO from Park 1 position and “RCAL” on that star with a hand controller. Then I click on SGP’s “Slew Now” button to slew to my target DSO but nothing happened and I noticed the stars were moving very slowly during frame and focus. At the time I didn’t realize the mount stopped tracking until I saw your post. So I re-slewed to the same star with hand controller and use SGP’s “Slew Now” again and it worked.

I also noticed I have A-P ASCOM version 5.06.02 but Ray Gralak’s web site latest version is 5.06.01. I wonder if 5.06.02 is buggy and it may have been suggested elsewhere to use 5.06.01 for same reason we are seeing.

My mount is A-P1100GTO.

It looks like I am not the only one seeing this. Thanks for posting.


I use AP driver 5.06.01 with my Mach1GTO and I’ve never seen this problem, but I usually don’t slew from within SGP, using instead my planetarium program to slew the mount.

I have seen this with my mach1 mount too. But so far I couldn’t repeat it
and don’t even know which program was responsible (skpro, tsx, ap telescope

I know, not very helpful, just another weak data point.


Thanks guys. I’m working on posting the logs.


What version of A-P V2 ASCOM driver are you using?


Here is the link to my log file:

I will check the version of A-P V2 ASCOM asap topboxman!

Thank you all for helping. At least I know I’m not crazy!

I am using AstroPhyscis_V2_5.06.01 Peter.

Thanks again!

Do you have ASCOM logs saved when your issue happened? It’s located in C:\ProgramData\Astro-Physics\ASCOM\Logs (for Windows 7).


Sorry for the delay topboxman…

Here is the log file:

Let me know if you need anything else!

I can’t really be sure what happened. SGPro connects just fine:

[2/27/2015 7:10:13 PM] [DEBUG] [Telescope Thread] Telescope: Implements MoveAxis...
[2/27/2015 7:10:13 PM] [DEBUG] [Telescope Thread] RA Move Rate Range: Min->0 Max->5
[2/27/2015 7:10:13 PM] [DEBUG] [Telescope Thread] DEC Move Rate Range: Min->0 Max->5
[2/27/2015 7:10:13 PM] [DEBUG] [Telescope Thread] Telescope: CanSetSideOfPier returned False

Then for 12 minutes everything is fine and suddenly, the connection to the mount is terminated:

[2/27/2015 7:22:24 PM] [DEBUG] [CP Update Thread] ASCOM Telescope: Error in GetCurrentPos : Lost communications with mount.

Maybe this is when you attempted to “Nudge” the mount. I’m not sure. Unfortunately the ASCOM log you provided starts at 21:31 so there is no correlation between the two logs.


First off thank you for taking the time to look at the log. I have uploaded the remainder of the logs from that night in hopes that one of them caught the issue.

Here are the other files:

( I believe if the first one did not contain the error this one should!)

And the remainder of the AP Logs:

This accounts for all of the data collected that night. Hopefully the fault is present here somewhere.

Thanks again!


Well… there’s a lot of stuff going on here and I am not sure what issues are related to software (some might be related to hardware communication?).

First, before you have any issue with the telescope, there was an issue with the focuser:

[2/27/2015 9:30:01 PM] [DEBUG] [Main Thread] Failed to connect to focuser. : Exception has been thrown by the target of an invocation. (System.Exception: serial port error when connecting)

This may be a red herring… maybe the focuser was not powered on or something, but thought I would bring it up.

Next you connect successfully to the mount and then immediately lose connection. None of your ASCOM logs show this period so I cannot say why:

[2/27/2015 9:30:42 PM] [DEBUG] [Telescope Thread] Telescope: Implements MoveAxis...
[2/27/2015 9:30:42 PM] [DEBUG] [Telescope Thread] RA Move Rate Range: Min->0 Max->5
[2/27/2015 9:30:42 PM] [DEBUG] [Telescope Thread] DEC Move Rate Range: Min->0 Max->5
[2/27/2015 9:30:42 PM] [DEBUG] [Telescope Thread] Telescope: CanSetSideOfPier returned False
[2/27/2015 9:30:42 PM] [DEBUG] [Main Thread] ASCOM Telescope: Error in GetCurrentPos : Lost communications with mount.

Then it looks like you connect again (successfully):

[2/27/2015 9:31:21 PM] [DEBUG] [Telescope Thread] Telescope Dispatch loop: Received SGM_TELESCOPE_CONNECT...
[2/27/2015 9:31:24 PM] [DEBUG] [Telescope Thread] Telescope: Implements MoveAxis...
[2/27/2015 9:31:24 PM] [DEBUG] [Telescope Thread] RA Move Rate Range: Min->0 Max->5
[2/27/2015 9:31:24 PM] [DEBUG] [Telescope Thread] DEC Move Rate Range: Min->0 Max->5
[2/27/2015 9:31:24 PM] [DEBUG] [Telescope Thread] Telescope: CanSetSideOfPier returned False

But… the mount is no longer tracking. I am not qualified to fully interpret the ASCOM logs, but from the second attempt:

000031 2015-02-27 21:31:23.126: Inititialization: Info      : Side of mount initilization complete!
000032 2015-02-27 21:31:23.137:             User: Info      : Stop tracking pressed
000033 2015-02-27 21:31:23.148:            ASCOM: Info      : SET Tracking = False

I am not sure why it indicates that the user stopped tracking. After this, the mount continually fails when SGPro tries to sync it because it thinks it is not tracking. When you use the nudge commands, we ensure that when the nudge is over, we send a Tracking = true to the mount (since we have seen some mounts stop tracking after nudge). This code, however, has been around for a long time (to include the older, probably less stable, code base you are using).

Hello all,

The “User Stop” issue is a known bug that will be fixed in an upcoming version of the driver. Unfortunately my test mount developed a hardware problem and had to be shipped back to AP so I’m waiting for it to be returned to me so that I can to debug the problem, In the meantime, if you locate the AP.INI file (in the directory “above” the logs directory) you can use this temporary fix:

Add this line to AP.INI when the AP V2 driver is not running:


-Ray Gralak


Thanks so much for taking the time to comment! I will add this line to the .ini and report back so the thread has a documented solution.

Thanks all for your time and patience!