SGP can't connect to QHY after PHD started

First time newbie. The other day I removed my old (6.2) ASCOM stuff in anticipation of the latest SGPro. I also updated the QHY drivers. For guiding, I use a QHY-II. WHen I started PHD and attempted to select the QHY-II, the only driver that appeared is QHY ASCOM Guider. I selected that, chose the ASCOM celestron mount and started PHD. It was daytime so I put it off until the next clear night. I started SGPro and selected the QHY ASCOM Capture driver and took a few quick shots, shut it down, and waited for night. Tonight, I went out, started PHD guiding, then fired up SGPro and tried to connect to QHY ASCOM Capture. It would not connect. When I clicked the chooser, the only ASCOM driver listed was QHY ASCOM QHYII Guider with some sort of GUID next to it. The pulldown with devices in SGPro also listed the native QHY driver. I tried that but same error. I went to PHD, disconnected the mount and QHY ASCOM driver, and shut it down. I went to SGPro (which was still running) and tried to connect the imaging camera and received the same error for both the ASCOM and native driver. I shutdown SGPro, then restarted it. This time, I was able to connect the native or ASCOM QHY imaging camera. I then went to PHD and restarted. I still could not connect the guiding camera. I went back to SGPro, shut it down, restarted it and selected the native QHY capture driver instead of the ASCOM driver. I then went to PHD, started it and was able to connect and calibrate. So I’m running SGPro with the native QHY capture driver, and running PHD with the ASCOM guide and mount drivers. Still, SGPro must be started first before PHD. If I start PHD first and select the QHY Ascom guide camera, SGPro never allows me to connect to any of my imaging cameras. I’m worried that is is one of those finger-pointing problems, and wondering if anyone else has experienced a similar behavior. Thanks.

I have seen something similar. Even though I am using QHY Capture and QHY Guide ASCOM selections, PHD2 can grab onto the capture camera and leave SGP high and dry. I need to write something to QHY about it, as it is possibly an ASCOM issue.

There is a fix. First, go into SGP and connect and first set up your capture camera. Turn on the SGP option to open PHD2 and select the profile you want it to use. Then, go into PHD2 and connect to the remaining QHY guider camera. You may want to save your PHD2 profile, and then you can disconnect and close PHD2 and disconnect SGP camera and close SGP.
In practice, I found that if I start a sequence in SGP and allow it to connect and fire up PHD2 in turn, it all plays nicely. I have this working on two rigs - a QHY247C/QHY178 and a QHY183/QHY178 .

I just tried it and it connected!! Will try imaging once the clouds roll out. Seems like a bug in ASCOM.

Here’s a few other data points. The clouds rolled in, so PHD was a binging and abonging, disconnected the guiding camera (QHYII) and mount, then closed it. Went to SGPro (I had been using the QHY10 native driver) and was going to try to connect to the QHY ASCOM Capture Driver. The only ASCOM driver available was the guide driver for my QHYII guide camera. I shut down SGPro and restarted it. The QHY ASCOM capture driver came back in the chooser, but I still could not connect to it. I ended up rebooting my machine, then was able to connect to the QHY Capture driver through SGPro. I didn’t dare start PHD, as it turns out more clouds rolled in so I called it a night.

I don’t know much about ASCOM, if it runs as a service or instance, but it does seem to be fairly buggy. The QHY folks should take a look at their code as well. All of this equipment had been working fine together for several years on ASCOM 6.2.


Yes - the PHD2 guys think is is likely to be a driver issue. In PHD2, you also have the option of not using an ASCOM driver, but their own (communicating directly with the QHY device driver). In the past, I had less issues with this approach for Lodestar, than by using the SX ASCOM drivers.

Bruce (PHD2 developer) thinks this is likely to be ASCOM driver related and I have raised a query on the QHY forum.

for info - I went to do a follow up with QHY on my query - but before doing so, confirm the problem is still there… guess what… I cannot get it to misbehave. It is possible a recent SDK update fixed the issue.

I have let QHY know and remind myself, if a problem like this returns, to note all driver versions at the time…

[update] - the QHY updater tool is not picking up on the latest release. It is stating it as 26/6/20 when QHY released new drivers two months later in August. Best to go direct to QHY website and install.