SGP_Customer

Whats up?

Purchased the renewal update.

Download SGP 4 and when I launch the program I have to approve that I am using beta software.

Whats up with that?

Then I try to link to support and I am told the email used to pay for my membership does not exist over here.

I don’t want to use beta software. I do not understand why 4.0.0.700 is asking for an approval when it is listed as stable?

Been a customer and user for years. What is going on?

chris123d hotmail.com

We failed to remove the beta warning from the stable release, but it has been corrected so future updates will not occur in the future.

If we are unable to find a match for the email address you used to purchase SGPro within the SGPro forum (different systems), you will be required to link them. This is just the process of telling SGPro what forum account you want to use. You can do this within the account management area of the SGPro website => https://www.sequencegeneratorpro.com/how-to-get-access-to-premium-support/

I have the latest beta and originally installed the released version. I too was disappointed to see that the first dialog on opening the released version was a “this is a beta - accept” - that doesn’t inspire confidence! You have to wonder who actually tests the release candidates before they get shipped…

I don’t normally try betas and prefer to only use released code. With the trial I have spent days trying to work out how to setup just a simply CMOS camera - looking at logs and reading the manual. Switched to the beta out of desperation. I couldn’t find any proof that offset is ever passed through to the camera ASI294MC and that gain set in the camera e.g. Unity Gain is overriden by the gain for bin 1x, 2x 3x 4x and the offset is initially “linked” but replacing with a number doesn’t seem to get passed through to the camera.

Compared to other S/W the learning curve is a bit steep. At times I just wanted to just give up. I found the Chris Woodhouse Youtube SGP series and this helped me a lot.

Knowing that the Equipment Profile needs updates as progress is made, I initially replaced my sequences frequently but now use File → Apply Profile to Sequence… and checked the current status in the Control Panel.

As a Newbie, the Profile Manager always reverting to a New Profile - is really annoying and it is easy to not change an already saved profile. It’s not clear why the New Profile button doesn’t provide this function so that the last set Profile can be initially shown. With about 40 days left on the trial I do hope to get everything setup and get an understanding that it does what I want…

Simon

Well… we do have a suite of tests that run prior to release, but they don’t cover every aspect of the UI. This was released in error because the test machines had used the “Don’t show again option” and they slipped by.

Also, keep in mind that this software is written, tested and maintained by literally 2 people and we do it when we get home from our regular jobs… If that’s something that doesn’t strike you as right, there are other options where this is not true.

I have been making progress with the trial and I have been comparing it to other S/W like Nina and Voyager. It is probably a Windows vs Mac thing, but because I started with SGP Pro and the others (being different) don’t really work for me. The more I use the program, the more I appreciate SGP Pro’s layout and how it offers choices. I do refer to the Help, have the manual and (as previously noted) watch Chris’s YouTube play list on SGP Pro.

Not wanting to criticise…

I did realise that there are only two of you and that you have day jobs too. My point wasn’t a criticism, rather it doesn’t help me to see the initial banner when I’m considering buying it. It really was the first thing I noticed and I searched for a different Release version. I have subsequently moved to the frequent Beta versions. I have found it best to uninstall and reinstall with a new Beta - it seems to help with stability.

I don’t know if your philosophy is to try things out in the Beta and if they work add them to the next main Release or if it represents the “Best so Far” in the journey to a Release? I’m assuming it shows how the product will look and operate at the next release.

Feature or potential bug?

As a Trial user I can’t raise bugs. I can look and see if they are already known. The best I can do is put something in the SGP Pro Support folder and hope it gets noticed. I did find a ‘feature’ with my Astro Pegasus Focuser because I read in the selection of my Focuser, that it is better to use SGP Pro’s backlash algorithm, so It tried it. With OUT + value it puts the count to ‘Unknown’ on a return to ZERO because the Focuser won’t tolerate a move that is negative. The log (the I also included in the topic clearly shows why there is an issue - for my Focuser.

FWIW, I compared the way Pegasus does backlash (they go past the point and retract, after every direction change) and SGP Pro that approach (from one direction - every time). Pegasus doesn’t have a problem with approaching ZERO. Since you are unlikely to find a real target at ZERO, it makes sense not to try backlash especially if it would go negative. I do however use IN + value without issues at either ZERO or my maximum, in SGP Pro.

On my Laptop - using the new themes can be slow

On my laptop that has a Rizen 5, the new themes seem to slow things down compared to the Release version. It may just be that I’m trying more of the options and so it loads more slowly. Using a Windows theme is very slow (on my laptop) - I don’t know if that’s because what is required isn’t cached or because you are collecting extra e…g. debug data that wouldn’t be in a Release version.

Simon

I have tremendously enjoyed SGP over the years. I can say that this is one of the most important components of how I do astronomy. This software got me the production I wanted. This gave what a $600 dollar copy of maxim did not. Screw nina…dummys want something for nothing. This software is very superior in everyway.

But here I am this morning and I try to fire up SGP 3 something on a system and here we go not loading up. Almost like the software was disabled. It was working perfectly for 2 years and here we go. I have not have this happen with a software unless it had a license? Was I turned off because of my comment here?

We have changed our licensing system (about a year ago), but any installs of SGPro 3 that has already been activated should remain activated. If you need to activate a new version of SGPro 3, then you will need to claim your new license to activate it, but no new purchases are required.

That said, it’s not clear to me what you mean by “not loading up”. Like SGPro won’t start? What do you see? Just the loading screen and nothing else? Or does it load, but only as the free version? I’m not sure what issue you’re reporting, but we can help.

I am not even sure to what comment you are referring, but I can assure you that we would never disable a license because somebody does not agree with us.

Here is a youtube to document the issue: Documenting SGP Not Starting 1.23.2022 - YouTube

Is that the right video? I don’t see any attempt to start SGPro in that video? Maybe I missed it? Can you give me a minutes:seconds marker?

Minute Markers:

1.56 SGP
2.00 SGP
2.05 SGP
2.20 SGP
2.35 SGP

2.59 Sharpcap Launched
3.07 NINA Launched

3.35 SGP
3.37 SGP
3.42 SGP

There is the evidence.

The reason I am extra hot on this is I have a dark site trip planned for the end of this week. I do not want to be surprised by the software not working under bortle 2 skies. I could have been surprise by a lack of cooperation from the software on this trip. I was surprised on a dark site trip before.

Hope you guys stay focused because I do love the software. I cannot imaging having to learn another software and discover the lack of good features your guys have developed.

Im not really sure… never seen that particular issue before.

  • Maybe the SGPro install is corrupted? Have you tried re-installing it (version 3.2)?
  • How about ASCOM? What version of ASCOM do you have installed?
  • Do you know what version of .NET you have installed?
  • Can you think of anything at all that changed on your system between when SGPro was working and not working?
  • Maybe that app shortcut is broken? Try to run the app directly and dont use the shortcut link. Go to file explorer. Usually, it’s here:
C:\Program Files (x86)\Sequence Generator Pro\

Then find and double click Sequence Generator.exe directly.

Finally, if nothing here works or stirs any ideas, a couple options:

  • we’ll need to see if SGPro produces any logs at all. SGPro writes logfiles to
C:\Users\[username]]\AppData\Local\SequenceGenerator
  • last, this will essentially reset SGPro, but your sequences and profiles can be saved:
    • Navigate to the directory above
    • Find and save the directory Sequence Generator Pro somewhere else that is not there
    • Then delete C:\Users\[username]]\AppData\Local\SequenceGenerator entirely.
    • If SGPro starts, you can replace the Sequence Generator Pro directory back where you found it
    • If it fails to start again, the problem is maybe with a corrupted profile… that said, I have never seen SGPro hang because of it.

I went through your troubleshooting instructions. I did reinstall ascom. When ascom was reinstalled, SGP was reinvigorated and fired up. Note all of my other astronomy programs were running without exception before reinstalling ascom to jump start SGP.

Guys keep faith in what you have done. This software has given me more value for dollar spend than any other money I have spent on anything in astronomy.

I have taken down the youtube video as the issue was solved.

Thanks

1 Like