SGP does not start anymore!

Hello to everybody here.

I am a French user of SGP since 3 months now. Great piece of software.
SGP has been working very fine since this night :

  • the program does not start, no log created, no error message
  • try to reinstall with, setup.exe does not start, no error message
  • have restored to a 15 days-old backup (at that time SGP was working) : same
  • try to start from the SGP program file directory : same
  • I did not find such case in the forum…

I am on Windows 8.1. I am currently trying to switch to Win 10. We’ll see.

Has somebody an idea ?



OK problem solved.

For an unknown reason, and of course without telling me (it is more funny to guess, probably) AVAST antivirus decided yesterday or two days ago to consider SGP as a virus !!!

The solution : add SGP in the exclusions of AVAST (zones not scanned - therefore not banned !!!)

1 Like

I think I had a problem with AVAST (free version) as well. A couple of weeks ago I posted here about a problem that the newest beta of SGP would not install, it would just hang mid way and force me to kill the process. I also tried with AVAST disabled and for some reason it still didn’t work. I finally uninstalled AVAST and went back to Microsoft’s security essentials and then SGP installed just fine. Still don’t know if that was truly the problem but it’s been working ever since.


1 Like

Yes, AVAST behaviour is unclear and false positives occur, especially with programs with reduced feedback from users, it may find safer to declare such program as viruses !

Well I use Trend Micro antivirus, and it deletes SGP every time I tried to install it. So I have to disable Trend Micro each time I do an upgrade. The reason it gives is that it is an uncommon program!!!


1 Like

I had the same issue with Avast 2015 free. It would not load both SGP or the latest issue ascom 6.2. Just kept throwing them in the virus vault. No matter how I tried Avast would not release them.
Uninstalled Avast and downloaded Bitdefender free. Loaded both SGP & Ascom with no issues.


Sounds like we should notice AVAST for these specific false positives.

I will try that and let you know.

1 Like

Below, the explanation of AVAST developers :
“since your executable file has no digital signature, AVAST can block it. We recommend that you put a digital signature in your file”

Probably the same kind of behaviour with ASCOM or others programs blocked by this antivirus…