SGP fail to load

SGP fails to load because of “invalid dome parameters” …I dont have a dome! I have a Roll off roof, but SGP keeps defaulting back to dome at startup, any Ideas why its not saving my ROR settings?

That is a bug I think, something gets confused and thinks you have a dome and as such need non zero dome parameters, been trying to figure out how to repeat it so can post it as a bug.

I would post links to your sequence and the equipment profile and see what they say.

The only fix I have found is to create make sure the profile is correct the load new sequence with profile but tick preserve existing sequence

Trevor Nicholls

A linked question which I have asked before but no yet seen a replay, the slave to telescope check box is set in the profile and when I load the sequence you can see it ticked by grayed out.

Connect the scope and stays ticked and grayed out, connect the ROR driver and it un-ticks and becomes enabled and I have to manually tick it again.

Anyone else see the same, is this a bug?

This is a bug that we had a while ago that wrote out invalid profiles. If you search your drive for *.sgp files, zip them up and send them over, we can see what SGPro hastes about your default profile.

Hi ken,

Not sure if this covers both the issue reported by Martin as well as the slave to scope but below is a link to my profiles, the profile


this has the issue Martin describes

All have the issue with the slave to scope being unticked when the dome driver is connected, would seen to be by design?

You seem to disable the checkbox, check if a scope is connected and then enable the check box ??

Unfortunately, the profile you mention does not seem to be in the zip file.

Sorry, don’t use the edge these days much - here is the the file

Cannot reproduce any issues with this profile (with 2.4.2). I am not at a machine where I can test with 2.4.1 right now.

I am running the latest beta, will run again with screen shots

Trevor Nicholls

ha! messy work.

Shots even - It’s late :smile:

Trevor Nicholls

Well thats typical! loaded up SGP just now to view the logs and it started 1st time, and I havn’t changed a thing.

Mine shows ticked and NOT greyed out all the time regardless of scope/ROR driver connection. I’m running V

Just completely uninstalled SGP, cleared all files and installed and just created a default profile with Telescope simulator for .NET and my ROR ascom driver and still the same behavior, after loading a new seq with profile the control panel has the box ticked by disabled, remains like when scope connected, when the Observatory is connected the box is un-ticked and also becomes enabled.

Screen shots of the 3 steps

Though interestingly if I leave them connected and load create a new seq with profile it comes up right

So either I have an issue with my driver but cant see what or I am misunderstanding how to set this up.

On the other issue with my Edge+PMX+QHY10+PHDv2.sgp profile, loading this in profile manager and attempting to click Slave Settings I get this

Full exception text

System.ArgumentOutOfRangeException: Value of ‘0’ is not valid for ‘Value’. ‘Value’ should be between ‘Minimum’ and ‘Maximum’.
Parameter name: Value
at System.Windows.Forms.NumericUpDown.set_Value(Decimal value)
at gx.bc(Object A_0, EventArgs A_1)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

One problem solved - sort of. The programe is hanging at the startup screen because of “invalid dome parameters”, but I couldnt get out of it because the “OK” box was hidden behind the Splash Screen…ctr-alt-del sorts it.

my setup -at start


That looks like you have the same, after you have loaded the profile and connected up the equipment the ‘Salve to telescope’ in the control panel is unticked and you have to manually enable slaving, my preference would be it sets that tick box as my profile.

As I manually open the roof for an hr or so before I start imaging I have on occasions forgot to check that tickboix when I load up SGP so the roof does not close at the end of the sequence.

For now I have code in my control program that checks the SGP log for scope parked/end of sequence and closes the roof if it is still open as part of the equipment power down routine.

Yes its is annoying I cant see why the setting cant be ported over from the profile to the control panel automatically, and, also in my case why the observatory setting keeps defaulting to dome when I have ROR selected.

Sorry you’re annoyed.

Because we have never been able to reprduce this behavior… Hopefully @trevorn has a description above that will help.

The slave setting in the obs profile was an oversight and it was never meant to be a profile “setting.” We have always considered “Slaved” an action like “Run Sequence” which we don’t automatically do when you connect equipment.

There are very few actions that take place in SGP only when equipment is connected. The only one that comes to mind is cooling the camera.

To rectify this we’ll be removing the “Slaved” option from the profile settings. We’ll also create a new option in the “Slave Settings” which will be “Slave on Connect?” or “Slave on Sequence Start?” (we haven’t determined which yet) which is what it sounds like most folks are wanting.

As far as the crashing when slaving is enabled I’ll have to go through @trevorn’s steps and attempt to duplicate.