SGP focuser selects hot pixels

Hello all,
I searched for this topic and could not find exact same issue. I have DirectSync Optec focuser and it worked very well until about a week ago. The curve started looking weird. Normally, my first point is between 4 and 5 HFR and I get to 1.5 HFR in focused point. Now my first data point starts with around 1.8-2.5 HFR. The reason for that is the focuser picks up dead pixels. The actual stars are looking like blobs and not selected by focuser. I use bining x2 and 6 sec exposure time. I have 6 pixels of smallest star and even when I changed it to 12 pixels, I just got to situations when no stars are selected in the far out positions. My step size is 75 and I use 9 data points. It worked very well until recently. I didn’t changed anything.
Thanks for any help.

Additionally, I did a darks library but it seems, it is not helping much.

Something must have changed (or a very different target)
Are you using the ASTAP utility for working out HFR? I’m just wondering if ASTAP uses the min star size setting (the min star size setting predates ASTAP)

Thank you Chris. No, I don’t use ASTAP. I am thinking maybe it is because too high light pollution. It started on a target not high over the horizon and bright skies. I will try it dark location, but now I don’t know.
Thank you very much for your videos on SGP and PixInsight on YouTube. I watched the dozen times. It is my main source of initial learning.

Best regards


I did some imaging last night and sky glow does have impact. In higher altitudes focuser performs better than closer to the horizon. How’re, not long ago I did not have problems, it worked like a charm. The focuser does not recognize blobs of stars at the beginning and end data points. What I can do to increase SNR of focuser? I had 6 sec before and with bin 2x2 it worked.

If SGP is not recognizing blobs at the focus extremes, one idea is to reduce the focuser step size. 6 seconds with 2x2 binning should be good for an f/7 or faster scope