SGP freezing at the end of the night's sequence


I’m having an ongoing issue that has affected me at the end of my last two sequence sessions. My sequence comes to the end during the dawn hours. The end is triggered by a predefined stop time for my last target. The following things do happen correctly:

  1. Guiding (PHD2) is stopped.
  2. The mount (Mach1GTO) parks the scope. I’m using APCC and the Astro-Physics ASCOM driver.

At this point, however, SGP freezes, and I am unable to access any menus, disconnect cameras, auto-focuser, scope, etc. I can’t tell whether or not the camera’s TEC has been turned off. The only way I can shut down SGP is to hit CTRL-ALT-DEL and kill the process.

This causes all kinds of things to happen including my ASCOM Moonlite focusing process does not shut down, the Astro-Physics ASCOM driver does not shut down, and consequently APCC won’t stop because of the driver still being connected. Nothing will shut down cleanly at this point, and I have to hit CTRL-AL-DEL to turn everything off.

What I would like to see happen is that the camera’s TEC is turned off, and SGP is simply waiting for my input to disconnect hardware, save the sequence file and shut down the software. Instead it is in an unresponsive freeze state, and all the hardware connect/disconnect buttons are grayed. None of the menus or buttons respond.

Obviously there is something happening with SGP at the end of a session, and I’d appreciate help figuring it out. My computer and any SGP log files are not available as I write this, but I could submit them later. (Where are those found, by the way?) Secondly, what should I see in the log files under normal circumstances at the end of a SGP session?

Thanks for your help with this!

Best Regards,

Please attach your log files and we’ll take a look. You don’t mention what version you’re using, but this used to be a problem in v2.4. If you’re still back there, please up date.

OK, I updated to the latest greatest version before starting last night’s session, and this solved the issue. This morning I found that everything had stopped as expected:

PHD2 guiding had stopped.
The scope was parked.
The camera TEC was off.
SGP was able to be closed out normally.

I noticed that the version I downloaded was only 2 days old, so I see why I missed it since I had probably set up my equipment before it was made available to download!

Thanks for the update!



I think that issue was corrected around 2.5.12 or so. I’m really glad that fixed it though!


I was still back on 2.4.X something, so it all makes sense.

Thanks again.


1 Like