SGP Hang After Slew

This was with Beta 5 but I have seen the issue previously. I did a slew to a new target then SGP was unresponsive. It looks like from this log file that SGP was busy talking to PHD2. I was guiding before the slew and, of course, PHD2 would have lost the star.

That’s interesting. I see your mount actually completed the slew and reported as much. You can ignore the chatty PHD2 stuff… that’s just how SGPro receives messages from PHD2… I’ll take a look.

After the slew, I did a center operation and it was SGP was responsive enough for that. However, I never got the confirmation dialog. For the center operation.

Here is another log file of the same again problem from tonight. After right click on an event select Slew to Target followed by right click select Center on Target - SGP hangs without showing Center confirmation dialog.

There is more than one slew operation in this log - look for the last one.

Here is another log with a difference. This time I did not do the slew - I just did a center request. Again, no confirmation dialog and SGP hangs. It looks from the log that some tasks are running but the UI is totally unresponsive.


I am not sure on this one. We asked your mount to slew and it never returned:

tel.SlewToCoordinates(tp.nRightAscension, tp.nDeclination);

Would need to correlate with the scope ASCOM logs to see what happened here.

I am not really sure I see what’s going on here. The centering was successful and then the sequence finished as expected.

I am not sure what this means. You mean to say that you right click on a target, select “Center on target” and then no confirmation shows up? The sequence just starts centering? Does the centering progress dialog show up? Are you starting the centering a different way?


Are you sure? I am seeing the last slew command starting here:

[1/21/2015 7:19:29 PM] [DEBUG] [Main Thread] Slewing to target…
[1/21/2015 7:19:29 PM] [DEBUG] [Telescope Thread] Slew telescope message received…
[1/21/2015 7:19:29 PM] [DEBUG] [Slew Monitor] Waiting for slew to complete…
[1/21/2015 7:19:29 PM] [DEBUG] [Telescope Thread] Telescope: Slewing to RA: 6.52333333333333 Dec: 5.00527777777778
[1/21/2015 7:19:29 PM] [DEBUG] [CP Update Thread] Error in control panel UI updater: Object reference not set to an instance of an object.

and ending here:

[1/21/2015 7:20:17 PM] [DEBUG] [Telescope Thread] Scope has completed slewing
[1/21/2015 7:20:17 PM] [DEBUG] [Telescope Thread] Slew complete…

That seems to show the slew completing in 48 seconds.

That seems to be the last slew I can see, I’m searching on “slewing”.
There does seem to be a different error reported though that seems to be something to do with the UI.

I’ve gone through all three logs and every start slew message seems to be matched to a completed slewing message.

It’s worth reporting the time that something happens so other people can find it.


Based on the last log, I think the center operation is one to look for - ignore the slew. In all three cases. I right clicked on the target, selected center, there was no confirmation dialog, and the SGP UI was unresponsive.

Where can I find the ASCOM logs?

Chris, you are right… I missed that in all the PHD2 clutter (which is going away in the next beta… just needed it on for a bit).

Peter, The UI thread really isn’t doing anything to lock it up so… I am at a bit of a loss:

  • Because this is true, I think that the conformation dialog might be appearing behind SGPro. Because it is modal, it would not allow you to interface with SGPro.
  • That theory, however, has a problem in that if the confirmation dialog was alive, but hidden, the action would not have started. I think you are saying the action does start.

So… another question: Does this happen all the time for you or is it sporadic?


On a sort of unrelated subject, when I first tried and tested Meridian Flipping with SGP, I first selected to pause BEFORE Meridian Flip starts. When it was supposed to be time to perform Meridian Flip, nothing happened and SGP was completely locked, I had to Ctrl-Alt-Del to close SGP and restart SGP. It turned out the confirmation dialog window may have been behind SGP window and I didn’t think about at the time to use Alt-Tab to change windows.

I created a thread about this but the thread seems to be long gone because I can’t find it. I think SGP’s response was that they were planning on not using Modal window anymore or something like this.

I ended up not pausing at all and let SGP do the magic for Meridian Flipping and Auto Centering and worked like a charm the first time.


Thanks for the hint for that. If the confirmation dialog is coming up behind the main window, it is likely because the dialog does not have the main window as a parent. Ken & Jarad this is something to check for all your windows.

Peter yes… I gave you that hint. I assure you that all of our windows are parented. Whatever is causing this to happen is far more insidious than a simple parenting issue.

You still did not answer my question. Does this happen every time or sporadically?

Just sometimes.