SGP Hangs/Freezes

Hello to all! This is my first post, and am new to SGP, so please be gentle!

I just took delivery of my new QHY183c, and had a very frustrating first light last night. I also just purchased Sequence Generator Pro, and am thrilled with the features it offers, but very frustrated with my experience with it thus far.

Last night, I ran many multiple iterations of simple one line sequences; typically with 1 or 2 minute exposure times, and 10 to 20 frames, each with a 5 second delay between. None of the sequences were completed successfully. Somewhere in the middle of every capture sequence I ran, SGP would hang up while downloading the captured image to my hard drive. I started with the USB traffic at 30, and worked my way down to 1 in increments of 5. Every sequence hung; some after 6 images downloaded successfully, some after just one. When an image was successfully downloaded it took about 3.5 seconds to do so. When the sequence hangs, I have to reset it, then SGP becomes unresponsive. Upon restarting SGP, and reloading the unfinished sequence (or a completely different one), SGP freezes and becomes unresponsive, forcing me to reboot everything. I have downloaded and installed all of the latest software for the camera, SGP and Stellarium. My laptop is a somewhat dated Windows 7/32 bit/4G RAM/i5/USB2.0.

I’d sure appreciate any help you could offer.


Logs would be helpful. Please see here:

Also from what I’ve seen the USB Traffic needs to be set to 0. I’m not entirely sure that this option does, just what I’ve found in a little bit of research. If it’s anything like the ZWO cameras the USB Limit can be used to freeze up the download when approaching certain numbers. Honestly I’m not sure why this is even user accessible.


This sounds like a USB timing issue. Are you using a USB hub? Also, I think you went the wrong way with the USB traffic speed. Try increasing that number.
However, if I’m not mistaken I thought that QHY changed the driver so that the USB speed didn’t matter anymore, and is not really user configurable. Make sure you’re on the latest driver.

I am on the latest driver from QHY. No hub. I’ll try again tonight with the USB turned up.

Jared - thanks for the heads up on logs - I’ll pull a couple and post tonight. I will also try taking the USB traffic setting to zero. I did in fact, perform several searches for similar issues before posting. I may have missed something, but there was nothing pertaining to QHY183c with any final resolution. Even the ZWO issues that appeared in my searches just sort of dwindled out after discussion about trying different USB settings, or driver versions, both of which I tried last night.