SGP has stopped working

Hi Guys

I’ve started having a problem with SGPro.

The last time I was out in the observatory a couple of nights ago it worked fine, but today it reports that it’s stopped working during opening as the Splash screen shows that it’s initialising logs.

In the end, I un-installed SGP and did a system restore, then reinstalled SGP …and it started working.

I had to re-install ansvr because since reinstalling SGP I’ve struggled tonight with plate solving using the local Astrometry solver but having got it all working in the end and having run all evening, it failed to solve prior to an auto meridian flip and froze up, reporting that it had stopped working. Now SGP won’t restart and reports that it’s stopped working again during the splash screen - exactly as before.

Any help you can give would be great please.

The log files from tonight are here:



It’s hard to be certain, but I would try moving all your profiles (sgp) files (location varies by OS… Windows 7, 8 and 8.1 are here: C:\Users<UserName>\AppData\Local\SequenceGenerator\Sequence Generator Pro) out of the folder they are in now and placing them somewhere temporary (like the desktop or something). Then try and start SGPro and see if it runs without issue. If this works, add the profiles back to the originating folder one by one until SGPro no longer starts properly. At that point providing us with that profile for inspection would be of help (assuming this is a profile issue).

Sorry, that would be:

C:\Users\YourUserName\AppData\Local\SequenceGenerator\Sequence Generator Pro

Hi Ken - that’s worked.

Thanks for coming back so quickly - great service - as usual!


Great. Do you have any sgp profiles we can take a look at? This shouldn’t happen.

No problems Ken - here you go.

Hope it’s useful


Thanks Steve. Of course, I added your profiles to my list and SGPro started with no issue (always happens this way). Do you recall if you had one of them selected as the default profile?

Ken - I owe you an apology.

The default Profiles Directory was set to a Network Address (my server) and we’d had several power failures over the past couple of days - I’m 99% sure that the server was down when SGP wasn’t working.

I’ve reset the “default back to the default.”

I recognise this is my problem, but as a suggestion since this appears to stop SGP in its tracks - would it be a good idea to “catch” this error and post a message box?

Sorry to have wasted your time!



You didn’t waste our time here… I am not sure where the code is puking (logs are not very helpful here). Reviewing this section is shows that we are fairly careful with loading of profiles (in terms of error handling). I have added a general “catch-all” handler for catching whatever it is that we are not seeing.

The unfortunate part with this “fix” is that SGPro profiles will fail silently. There will be a message in the logs that this happens, but no pop-up message. Unfortunately, the profile data loads into memory before any windows are present.