SGP Hung at Waiting for Guider to Settle

I had some strange behavior last night. I was using SGP (64-bit) and PHD 2.6.9dev3. This combination has be working fine for several nights, but then last night SGP hung at the waiting for Guider start up after starting a sequence. When I went to the PHD screen, the guider was working but the RMS error stats was showing 0’s even though there was obviously error in guiding. If I then pause the sequence and then go to PHD and manually start the guider, it works fine and the error stats show correctly.

I know that the previous dev versions of PHD would hang with multi star guiding, but this latest version was working fine. It did this every time I tried, even after completely restarting the computer. When SGP initiated the guider the stats would be frozen and SGP would hang at waiting for guider to settle, but PHD worked fine when not initiated by SGP. I ended up re-installing the PHD 2.6.9 Production build and it worked fine, but I lost the multi-star guiding capability. Any ideas?