SGP not reading SXV M7 in Interlaced Mode

I am trying to use my old Starlight Xpress SXV M7 CCD camera with SGP. However, when I do, I get horizontal banding through all of the stars as demonstrated in the attached image:


It appears that the problem is that SGP is not reading the M7 in ‘Interlaced’ mode (apparently, there is a well recognized phenomenon with the SXVs when used in ‘Progressive’ mode called the Venetian Blind effect, which what I appear to be seeing when using it with SGP).

Is there a way to make SGP to read the SXV M7 in ‘Interlaced’ mode? I understand that Maxim DL has a driver that allows it to read the SXVs in ‘Interlaced’ mode but I cannot find anything similar for SGP or a setting in the ASCOM SX Camera Set up that will make SGP do so.

Take a look at Page 17 of this handbook - it relates to M9 camera but I guess it is the same.

Many thanks. I have managed to get Star2000 working on Windows 10 using the correct WSC32.dll file. Star2000 allows me to take the camera out of normal mode and into ‘Progressive’ or ‘Interlaced’.

The only difficulty is that setting is not held by the camera unless Star2000 is kept open.

It remains to be seen whether SGP will read the M7 according to the settings set in Star2000 whilst the camera remains connected to the latter programme.

Many thanks again.