SGP says meridian flip failed, but it didn't

I’m using an iOptron iEQ45 Pro mount. I tired an automated meridian flip but it failed, even though the mount actually did execute the flip.

To Try to narrow things down, I tried initiating the flip myself from within SGP. I shut off all the plate solving and centering to get that out of the way. I set my mount to flip at 5 degrees past the meridian so it wouldn’t be executing the flip itself.

I aimed the mount at a target that was just before the meridian. I hit the Run button in SGP to initiate the flip. Nothing happened and SGP said it failed. I’m assuming this was perhaps the mount not allowing a flip before the meridian had actually been reached. (?)

I waited a few minutes till the target was just past the meridian. Hit the Run button, the mount executed the flip, and SGP indicated that a slew was in progress. After the slew completed, the SGP flip-progress window said that the meridian flip failed. But it had completed just fine, and the mount was pointing right where it should.

What’s going on?


Please see this and we’ll see what we can find:

I have the same mount and this evening I had a similar situation. SGP said it was past the meridian, tried a flip, and said it failed. Still in progress with tonight’s run - will supply log later.

I can still provide a log for this but I think I am better understanding the issue. In previous sessions, I had the mount set to flip at the meridian and I found that the mount was flipping on its own while an exposure was in progress. So I set the mount to flip at 5 degrees past the meridian and SGP at the meridian. It was with this setting that SGP attempted a flip and reported it did not flip. So I think what happened is the SGP saw that it was past the meridian so it issued a slew command to the mount but since the mount was not at 5 degrees past it did not flip. So it would seem the only option would be to use the Wait for Meridian option in SGP. This seems like a nasty catch-22 situation between the mount and SGP. The mount has the option to either flip or halt at the meridian or sometime after it. Ken or Jared, could you comment on this? Any suggestions on setting this up?

Log would still be helpful so we can actually see why SGP thinks the flip failed.

“Wait for meridian” would likely not work and 1 of 2 things would happen (likely randomly)

  1. SGP would attempt the flip. This would be the case if SGP calculated that the meridian was hit before the mount. Then we’d be in the same situation that you’re in now when SGP flips and reports error.
  2. (A fun new case!) when the mount flips on its own while SGP is waiting. SGP would then do 1 of 2 things:.
  3. Issue another flip.
  4. Detect that a meridian flip is not needed (I’m not entirely certain this would happen).

Either way, you’re in uncharted territory and I would not recommend 2 things trying to control the pier side of the mount.

You may also want to review these 2 threads (the CEM60 thread is quite extensive and I worked with iOptron engineers to get their meridian flip code corrected…however I’m not sure if it made it’s way to the ieq45. My knowledge of the iOptron firmware and ASCOM isn’t extremely deep.)


Ok, based on what you are saying and the way ASCOM works I think the best option is to set the mount to stop at 5 degrees past the meridian (for safety) with no auto flip and set SGP to flip at the meridian (That is, after the an exposure that takes it past the meridian.) That would allow up to 15 minute exposures with a little safety margin.

If SGP had the knowledge that the mount auto-flips (e.g. some SGP option setting), it could deal with a mount that auto flips but that is not the case.