SGP Sequence Crashes When on Sequence Creating Flats

Link to SGP Log File

I just received a new Flat Field Illuminator that I was attempting to try out tonight. I was not using SGP to control the Illuminator. I installed the illuminator on my telescope and manually adjusted the brightness until I was satisfied with the illumination. I then setup a simple sequence to take five 1 second images and store them in my Flat directory. I tried running the sequence several times and each time SQP would crash after taking one or two images. The only equipment I had connected to SGP was the SBIG Camera.

I ended up generating several flat files, but I had to do them one at a time by setting the sequence to take one image and then reseting and re-running the sequence after each image was completed.


@fjkeller This is an insanely long thread (you don’t need to read it all), but I think we finally have the issue resolved. This is also the issue you are experiencing:

It is probably pretty safe to download and use at this point.


Thanks for the quick response. I am currently running version of
SGP. If I upgrade to the beta version will I retain all of my current
settings. Also, is it easy to downgrade back to if I have any
issues with the latest beta version?



Mostly. There are some settings that have moved from “global settings” to “sequence settings”. These will need to be re set in order for your sequence to function properly.

Yes, but downgrading requires a full uninstall, then install of the downgraded version.

I am running the latest 2.5 Beta and am able to take no more than 3 flats in a sequence before SGP crashes back to Windows (7 SP1).


Please take a read through this and we’ll see what we can find (not the searching the help file and forum, just the instructions for log and sequence files).


I am using beta and was not able to generate more than 3 flats
per try before I crashed back to Windows 7. I started SGP from scratch
just to generate the flats and had four crashes in a row within a few
minutes. See files below…

This morning I tried to duplicate the crash but was able to take a
series of flats with no crashes.

Please let me know if you need anything else.


Thanks Tom,

We don’t technically support all aspects of UNC path naming. Can you please map your file destination to a driver letter and use that instead?



I am not familiar with the UNC path naming issue preventing you from seeing the Dropbox contents…could you elaborate as to what you want me to do to access the four files?

I uploaded the files to Amazon cloud drive if that helps…


I think he means don’t use a network drive to store your images. Instead map them to a drive letter and see if that fixes your problem.

Thanks, I’ll give that a go. Odd thing is only doing flats causes the crashes.

1 Like