Sgp won't connect to phd2

Hello, At the beginig of a sequence, phd2 allready launched and equipement connected i have this :
"the autoguider is not running or the connection is lost "

I can see the phd 2 graph in sgp , and sgp i then able to lanch the guiding after this dialog box.

here’s what the log says :

"[23/03/2015 02:19:48] [DEBUG] [Sequence Thread] Connecting to PHD2…
[23/03/2015 02:19:48] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Stopped
[23/03/2015 02:19:48] [DEBUG] [Sequence Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

[23/03/2015 02:19:49] [DEBUG] [PHD2 Listener Thread] Failed to establish client connection to PHD2 using port 4400: Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée
[23/03/2015 02:19:49] [DEBUG] [PHD2 Listener Thread] PHD2 connection terminated…

is it a normal behavior ?



It is not. Do you have some other server application occupying that port?

I think the error says that the connection was refused? Can you translate?

If you shut down PHD2 and SGPro and restart, do you get the same behavior every time (is it consistently repeatable)?

How about restarting the machine? This will guarantee anything holding on to that port is released.

thank Ken.

was late when i posted this.
i can reproduce this behavior.
i will check if i have no special,port protection somewhere…

So, no more chance to obtain connection to phd 2

the same occurs : here 's a translation :
" no established connexion because target computer explicity refused it "

i did allows all permitions through firewall so now i’m stuck.

In fact the only thinsg working is if i set the autoguiding ON on PHD.

-pause autoguiding is ok.

But sgp isn’t able to launch automatically the loop, the calibration, the guiding…

If i allow recovery mode, then the recovery mode is able to completly lauch the loop, calibration and guiding…
so now what can cause the first attempt to launch the phd2 whole thing to not works ?

I experienced a similar problem tonight, logs to follow tomorrow.
PHD and SGP up and running cal and guiding were decent, as soon as or right after I started image capture PHD would stop guiding, this happened if I was guiding before starting sequence or if I let the sequence start the guiding.
After that PHD would not release the camera and I had to restart the computer, did that three times and gave up (for now)
I tried this with the PHD SVX and Ascom SVX, no joy.
Dell I7, WIN 8.1. Was working before I downloaded and installed the 2.4 release, was using the latest Beta before that.

Can you both please send log files and sequence (sgf) files that you are using?

will do that tonight.

Here is a dropbox link to some logs

I have been looking through the documentation as something like this is usually due to an error on my part.
I seem to remember a blurb somewhere about the mount being on camera or Ascom through the mount in PHD, I cannot find that note.

I am using an IEQ45 pro with the latest firmware and Ioptron Ascom driver.
Last night I was using “on camera”


Here’ are my logs : archived.

i did used simulators because the sky is cloudy, but the whole errors are the same with connected equipement.
I guesse this is a processing error from my part, and maybe i do not fully understand spg documentation.




I am unable to locate any issues in the log you provided. Everything looks like it worked just fine. Here is the PHD2 connection code from when the sequence started:

[24/03/2015 21:13:31] [DEBUG] [Sequence Thread] Connecting to PHD2...
[24/03/2015 21:13:31] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Stopped
[24/03/2015 21:13:31] [DEBUG] [Sequence Thread] Sending to PHD2:
{"method": "get_app_state", "id": 1001}    
[24/03/2015 21:13:32] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Stopped
[24/03/2015 21:13:32] [DEBUG] [Sequence Thread] Successfully connected to PHD2...

I don’t see any errors or anything like that.

@Peter You didn’t state what kind of problem you are having. Because of this, I assumed they were similar to the other posters. Unfortunately, all of the logs you posted also show no issues when connecting to PHD2.

no this is at the beginig of a sequence that’s ther’s a problem :
If i understand well, there’ no guiding launch at the beginig of the sequence, then a recovery is trigged to force start the
autoguider… why the guider does’nt launch automatically ?

[24/03/2015 21:13:32] [DEBUG] [Sequence Thread] ********** Run sequence started **********
[24/03/2015 21:13:32] [DEBUG] [Sequence Thread] DoEventGroupChange: Changing to event group: Target Set 1
[24/03/2015 21:13:32] [DEBUG] [Sequence Thread] Checking for start delay…
[24/03/2015 21:13:32] [DEBUG] [Sequence Thread] Delay found… waiting 11 seconds…
[24/03/2015 21:13:32] [DEBUG] [Sequence Thread] Delayed start. Commencing sequence in 11 seconds…
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] DoEventGroupChange: Complete
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Attempting to find next event…
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Current event[0] frame count: 0/1…
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Looking at event[0]…
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Found event event[0] with remaining frames.
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Event[0] frame count: 0/1…
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Getting first event (0)…
[24/03/2015 21:13:43] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Running capture event…
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] ------------- Starting capture frame for event[0] -------------
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Created base name for frame capture: Target Set 1_300sec_1x1__frame1
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Created directory for frame capture: F:\Users\fdx1\Desktop\PHDLab_Win\Light
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Sending commands…
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] SetFlatBox: Frame Type is non-flat
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Checking for auto manual focus (pre)…
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Resuming auto guiding (settling)…
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Stopped
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Stopped
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] PHD2: Requested unpause, but PHD2 reports it is not in a paused state
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Stopped
[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

[24/03/2015 21:13:43] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Stopped
[24/03/2015 21:13:44] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Stopped
[24/03/2015 21:13:44] [DEBUG] [Sequence Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

[24/03/2015 21:13:44] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Stopped
[24/03/2015 21:13:45] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Stopped
[24/03/2015 21:13:45] [DEBUG] [Sequence Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

[24/03/2015 21:13:46] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Stopped
[24/03/2015 21:13:46] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
[24/03/2015 21:13:46] [DEBUG] [MF Update Thread] Performing serialize…
[24/03/2015 21:13:47] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Stopped
[24/03/2015 21:13:47] [DEBUG] [Sequence Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

[24/03/2015 21:13:47] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Stopped
[24/03/2015 21:13:48] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Pre-Wait : Stopped
[24/03/2015 21:13:48] [DEBUG] [Sequence Thread] Sending to PHD2:
{“method”: “get_app_state”, “id”: 1001}

[24/03/2015 21:13:48] [DEBUG] [Sequence Thread] PHD2 GetPhdStatus - Post-Wait: Stopped
[24/03/2015 21:13:48] [DEBUG] [Sequence Thread] Request to settle auto guider has failed. Guider reports it is not guiding…
[24/03/2015 21:13:48] [DEBUG] [Sequence Thread] Recovering the sequence (while attempting to dither or settle the auto guider)
[24/03/2015 21:13:59] [DEBUG] [Recovery Sequence Thread] (Recover) user try again…
[24/03/2015 21:13:59] [DEBUG] [Recovery Sequence Thread] Something bad has happened… attempting to recover the sequence (attempt 1)…
[24/03/2015 21:13:59] [DEBUG] [Recovery Sequence Thread] Recovery method using guider has started…

Thanks. I see what you are saying for this particular case… BUT, the sequence you sent does not appear to be “real”. I did find a small bug that would cause your test sequence to act this way, but in your real sequence, did you have “Dither” checked? If you did, the issue I just fixed would not have affected you.

Also, I could not find any issues with port blocking in your logs.

My problem is that during the sequence PHD 2.4i stops guiding, everything is still connected, but the graph is no longer moving.
If I try to disconnect or stop guiding in PHD to attempt a restart, PHD says “waiting for devices” and there it sits until I shut it down. When I do shut it down I get the msg “do you want to stop while capturing is active” (or similar).
Last night it would stop during the first frame.
Tonight, in fact minutes ago, it stopped guiding either during or right after the last frame #4 of event 1 of the sequence I have in dropbox.

It made it a lot further tonight.

Can you point me to one of the log files that shows this behavior? You have 4 or 5 in the dropbox folder.

I just put one in there with todays date 3/24/15
The graph makes it almost all the way across the screen and stops.

It may still be guiding, I looked at my first 4 images tonight in Pixinsight as my screen stretch with mouse does not appear to be working (it is checked).
The stars are round.

I still cannot stop the guider though, I am still imaging and we will see what a 10 minute Ha looks like in a bit.

It is not guiding

One other thing I feel I should note, is that considering the problems I had last night, tonight I had PHD guiding for at least 10 minutes on a random star before opening SGP.
When I open SGP and initiate imaging is when all the problems begin.
Sorry for the multiple replies


no more ports blocking.i justgessed before that sgp was able to execute
phd 2 by itself… thus sgp was asking for a port that was not open
(it open only when phd is executed)

My test sequence is near my real sequence :
i m allready at target so the sequence is simple:

take first light etc…
but the autoguider doesn t launch and recovey occurs.

does it linked with settle or something?

There was a bug where SGPro would not attempt to start guiding if you did not have “Dither” checked. In your case, it seems you might have only been after “settling” with no dither so the bug created a situation where there was no attempt to start guiding and went directly into recovery mode.

Well sure… SGPro is manipulating PHD2s status.

Also, it looks like you only posted the PHD2 log for the 3/24 run. Do you have the corresponding SGPro log?