SGPro and VPHOT issue

I used my friend SG Pro to test using SGPro to do my variable star imaging in a automated fashion. His version is v3.0.3.169. It worked fine.

So I bought my own copy of SG Pro. My version is V3.2.0.660. When I upload my images to VPHOT it is plate solved in VPHOT, except it doesn’t work with my version.!!!

Here is what another SGPro user said using one of my files…

I’m stumped.

  • Vladimir sent me an image of X Leo. The only thing I noticed was that the telescop field in the FITS header did not match the VPHOT field, but he said this change gave him a PinPoint error.*

  • I uploaded the image to Astrometry.Net and it solved fine. Plate scale and image angle were as in the FITS header. I uploaded it to the program I use, MPO Canopus, and it plate solved fine, which is interesting since I did not change the parameters of my setup to match that of the X LEO image. I uploaded the image to PinPoint in my setup and it plate solved fine.*

  • I am not sure where the breakdown is, but his image plate solves fine in 3 other plate solving engines, which is especially puzzling since VPHOT uses PinPoint to plate solve and PinPoint solved it fine for me. Best regards.*

I am a wits end trying to find a solution to the problem. I realize that there is a very, very high probability that the issue is with VPHOT. This is just a shot in the dark.

However, were there any changes between the two versions of SGPro that changed the plate solve routine or parameters??? Anything that I can look at and change in the FITS file that will help running down the “error”.

Thanks for your reply in advance.


Are you and Vladimir both using the same plate solver selection with SGP ?

Most folks now use ASTAP. All these plate solvers need some help to start with. It is good practice to check the focal length, pixel size and pixel scale are set up correctly in both your programs. The other gotcha is if the binning is different in the frame and focus tab, as I think it assumes that it is the same as for the image if you are simply doing a plate solve of an imported image.

Not sure, I will check.

However, we just spent two hours trying to find the source of the problem. Pretty sure that the issue is with VPHOT and not SGPro.

But one thing did come up. How do I keep SGPro from writing information to the FITS file. Not the important stuff, but things like TELESCOP and OBSERVER??


These files that will not solve… do they have the mount’s assumed RA/DEC in the FITS header?

Yes, but what they do have is TELESCOIP and OBSERVER and a few other FITS headers that are put there by SGPro (that were not there in the previous version). I don’t know if I didn’t set up the personal or equipment profile incorrectly in SGPro the first time and that is why it worked!!

It looks like the personal profile in SGPro is just the observatory location?? Will SGPro work if I leave the telescope and observer fields blank??? That information is also in VPHOT and that might be part of the conflict.