SGPro Hangs on Creating Default Sequence

Sorry to bother the group.

This is a brand new Dell Inspiron 3000, Windows 8.1 that I’m installing in my observatory.

I loaded SGPro 2633 yesterday and thought that it started fine. I recall organizing the Docking Modules to my taste, but I could be wrong here. I was running the W8.1 next to my home W7 computer, and loading most of the software and drivers while it was in the house.
Once in the observatory I found that the Windows 8.1 computer would not get past the “creating default sequence” on startup.

FWIW, I’ve included some logs from early and late in the day for the Windows 8.1. Also is one log from the Windows 7.1.

I also tried v2638 with the same results. Any help would be appreciated.


Is there any chance that the Win 8.1 machine is connected to some type of network that has no internet connection?

Thanks Ken for responding.
Yesterday when installing SGPro r2633, the Windows 8.1 was in the house and using the house’s wifi for installation. Otherwise I would not have been able to install. I have today tried the computer both in the OBS (with no wifi), and back in the house with wifi. But keep in mind that SGPro r2633 (and now r2638) were installed successfully. I do not see this as a wifi issue.

Getting old, but I know that the initial installation and run of r2633 (yesterday) was fine. As mentioned, I arranged the Docking Modules. Not previously mentioned was that I customized the equipment manager profile and saved it as StandardProfile.sgp.
I’ve added the file to the original DropBox folder for your review.

I was hoping the logs sent would give some insight to what has happened. Starting to worry a bit.



They did lend insight which is what led to my question. The sequence and profile load fine and then SGPro hangs while attempting to check if there is a more recent version available for download. If there is no network this fails quickly and we move on. If the machine thinks there “might” be an internet connection, it will try and check for a while.

OK Ken,

I think there are a few holes in that theory since the computer has been both within a strong wifi signal, and also essentially no wifi signal. And has not worked in either case.

Since the box is in the observatory, I’ll make every effort to make sure it does not pick up any faint wifi signal. I’ll let you know either way.

Glad to hear the logs helped.



See the attached DropBox.

  1. The “SGP Startup Issue” shows the SGP start window and a warning about incorrect Slave Settings.
  2. The “Dome Control Slave Settings” image shows the Slave window under the “Other” tab in the Equipment Profile Mgr.

The warning about Invalid Dome Parameters came up about 15 minutes after I tried to start SGP. A click on the warning window opened SGP. An input of “2” in the Allowable Error box in the Observatory Settings (image 2 Slave Settings) eliminated the hanging problem.

If all the data boxes in image 2 remain blank, and LesveDome has been selected as the Observatory under Equipment (in the Sequencer window), the hanging at startup occurs. Fortunately, SGP will eventually send out the error message and allow itself to open. And then the addition, in my case, of one value into the window shown in image 2 corrects the problem.

Is it practical to add some protection from falling into this trap?

Thanks again for your help. It is genuinely appreciated.


Yep. We’ll take a look.

So can you “toggle” this on and off by changing that value from 0 to 2 and back again to 0?

I’m not seeing how changing this value would make the default profile fail to load. I’ve been through multiple paths and I just can’t seem to find a case where the “Allowable Error” could conceivably cause this, not that I’m discounting your experience…I just can’t seem to find a path where that specific value would cause this.

I can’t duplicate this here, so would it be possible for you to set the allowable error back to 0, save the profile and see if it still hangs? My working theory at this point is that the sequence was corrupted, but re-saving it should cause it to be overwritten.

I have added some additional protection to that form but really those values only matter once the checkbox to enable slaving has been set (at which point you’d get an error message about the dome diameter being 0).


Hi Jared,

I’ll be happy to do that. Nickel says it still hangs though.
I know there is somehow a conflict between the Lesvedome slave settings and the SGPro slave settings. If Lesvedome is set to 2 degrees allowable error (typical value), and SGPro’s is left at 0, then the hanging occurs. However, when both SGPro and LesveDome are set to 2 degrees, then all is well. I suspect that the same would be true if both were at 0 degrees. Either way, I’ll let you know tomorrow.

The reason I asked if there was something that could be done in the software to protect me from myself is because this is one of those silent screw-ups. You don’t know you’ve done something wrong until the next time you try to start SGPro.


I’ll be the first to admit I’m not very familiar with Lesvedome. However you should only be slaving your dome in one application. So if you prefer to use the Lesvedome then you should not use SGP for slaving and vice versa. If you ONLY want SGP to open/close your shutter and Lesvedome to handle the azimuth slaving then you should tell SGP that your observatory is a roll off roof and it will not attempt to do any azimuth slaving which sounds like it might be where the problem is.

I should also mention that SGP has no knowledge of any of the slaving settings in LesveDome. So if the allowable error in LesveDome is 2 degrees and you’re also slaving in SGP with 0 degrees then SGP will just keep telling your dome to move until it’s within this allowance. Which LesveDome will likely block. This is one of the reasons it’s bad to have 2 applications slaving your dome.


Hi Jared, sorry for this thing below. This is fairly complicated (for me), so I apologize if it is not presented clearly.

I used six variables.
1. Equipment Profile Mgr:
a) “Lesvedome” or “No Observatory” — in Other/Other Eqpt Options/Observatory
b) “2” or “0” degrees Allowable Error — in Other/Other Eqpt Options/Observatory/Slave Settings/Obs Settings
c) “96” or “0” inches Dia. at Equator — in Other/Other Eqpt Options/Observatory/Slave Settings/Obs Settings

2. ASCOM Lesvedome Setup
a) “2” or “0” degrees Position Tolerance — in Lesvedome Setup
b) “170cm” or “0cm” Dome Dia. — in Lesvedome Setup

Here’s a table from the above choices:
1 LesveDome_______2_______96________2_______170_______NO
2 NoObservatory2_______96________2_______170_______NO
3 LesveDome
4 LesveDome________0_______96
5 LesveDome________0
6 LesveDome________0
7 LesveDome________2_______96________2_______170
8 LesveDome________2_______96________2_______170_______NO
9 LesveDome________2_______96________0170_______NO
10 NoObservatory0
11 NoObservatory_____0________0

Note that:
A) Items 1a, 1b and 1c are all SGPro Equipment Profile settings.
B) Items 2a and 2b are Lesvedome Dome setup settings.

Regarding the table of 11 variable combinations:
A) Lines 7 and 8 are repeats of line 1.
B) Line 6 is a repeat of line 5.
C) Line 5 hung for 35 minutes before giving the error note.
D) Line 6 hung for 7 minutes.
E) Line 10 surprised me. It hung for 1hr and 7min until I Killed it.
F) Line 11 was created between SGPro startups by changing the Lesvedome Position Tolerance to 0. While it did hang, fortunately it was for only 1 minute.

I did not expect line 10 to hang. I may be incorrect about how well the exclusion of Lesvedome and the inclusion of No Observatory protects SGPro during startup. But this one still bothers me.

If this table survives the transmission, you should be able to see the common thread with the Hangers. Every one of them has 0 in both SGPro locations. The Lesvedome settings appear to have no impact on this short list of tests.


Hi Jared,
Thanks for your thoughts. Here are some responses to your points.

  1. There are no other functions in the dome other than to “slave” the movement of the dome to the scope travel. No doors, no shutters, just dome rotation.
  2. I do not slave the dome to both Lesvedome and SGPro. Only to SGPro. The ASCOM Dome Control window is where I have historically startup Lesvedome and slave dome to scope. But since SGP, I do not do that anymore. I go to SGPro Sequencer/Equipment, and connect the Lesvedome in the observatory window. Once done I go to Control Panel/Other, and click Slave to Telescope. By this time the Slave Setting must be correct, or I would not have gotten this far.
    The ASCOM Dome Control (Lesvedome’s) becomes non-functional once the slave to SGPro is done.
  3. I’ll defer to you on your point about SGPro having no knowledge of the Lesvedome settings. However, there must be a Lesvedome driver loaded on the computer for it to work, and SGPro does recognize the driver. Otherwise that choice would not show up in your equipment selection.
  4. Lastly, the conflict twixt the 2deg on one location with a potential 0deg on another feels right. It’s just that from a practical standpoint, you can’t open SGPro if this combination exists. It’s not that the dome gets conflicting instructions. You’re just stuck at the start.

I like SGPro. I’m going to like it even better now that my brand spanking new Dell Inspiron 3000 64bit is setup in the observatory. The old Vista was sad. I know that it would take all of 10 seconds to startup and slave the dome from the ASCOM Dome Control, but I would just prefer to run my dome from the SGPro controls. Why not? It works.

Thanks for all the diligence here! Do you happen to have a log from one of the runs where SGP eventually started?

Yes, SGP does know about the driver. But, what I was meaning, is that SGP can’t read things like the Allowable Error from the driver

So you manually close the dome? Just wondering myself.

So it shouldn’t be getting conflicting commands if only one thing is slaved to it. I’ll try and pull the Lesvedome driver. I believe there is a trial.


I’ve DropBoxed a couple of log files to you. The one ending in …722 is when SGPro was hung up. The one ending in …725 was an actual shoot session a couple of days later. All went well with this one.

Not sure what you mean with your second point.

Yes, I close the shutter (and shut everything down) manually. If all goes well with a session, I can do that in the morning. Also I don’t shoot when there’s a chance of rain.

Pierre has offered his Classic Lesvedome for years. Within it are a setup for both dome and scope. In the dome setup there is the “Position Tolerance” which is the equivalent of SGPro’s “Allowable Error” (see my tabulated results from my last post). This is the method I’ve used for six years to connect the dome and scope. It’s a mix of his code working hand-in-hand with ASCOM’s POTH (I think).
Now leaving Lesvedome behind, when I connect SGPro’s Observatory (using LesveDome’s driver), I believe that SGPro only picks up the Dome information from LesveDome. Because I must also connect the Telescope (using Meade LX200 Classic driver), and then go into Control Panel/Other and check “Slave to Telescope”. Then they communicate.


I realize this is an aged thread, but I just had the same “invalid dome parameter” during launch “creating default sequence.” I have the beta 2.4 and had the dome simulator .net selected. Went to task manager and kill the task and then the program launched.

Hi Alex,

You’re smarted than me. I waited until SGPro eventually came up, and then edited the slave settings. I get a headache just reading the above.
To quote me … "If Lesvedome is set to 2 degrees allowable error (typical value), and SGPro’s is left at 0, then the hanging occurs. However, when both SGPro and LesveDome are set to 2 degrees, then all is well. I suspect that the same would be true if both were at 0 degrees."
Of course, that was for me and my equipment and software. Your mileage may vary.
Good luck,