SGpro + PHD2

hello I’ve been trying out the demo of sgpro recently and everything works very well apart from 1 thing and that’s SGpro and PHD2 talking to each other

in my equipment profile i have phd2 selected with a dither but the 2 programs don’t appear to be talking to each other

is there another setting that i need use ?

when i use APT and PHD2 for capture the 2 programs talk to each other just fine

any help would be gratefully appreciated


Hi Jake,

Welcome to the group.

Could you be a little more specific… what is the problem you are having that is leading you to believe the programs are not communicating?


Hi Andy. When I started my sequence it plate solved and centred everything just fine but then the sequence paused while it said it was waiting for PHD

I should have paid more attention really so I could be more specific, in the end I removed PhD2 from the auto Guider settings as I couldn’t get it to actually start the sequence

When I have used PhD2 with apt in the past, I would start PhD2 then start apt, apt would auto connect to PhD2 and in the bottom bar of PhD2 it would state new connection. This doesn’t happen with sgpro



Can you make sure you’ve installed the latest development build for phd2. I believe SGP requires at least 2.4.1i.

I’ve got the very latest builds of both programs.

Should PhD2 show something in its log file if sgpro is connected ?

Hello, in phd u set the server option active?the the prg will communicate together…and first start phd then sgpro

Yes the server is active and I start PhD2 first


We’ll need to see your SGP log and PHD2 Debug log.


Does it need to be from last night or can it just start the 2 programs now and then post the logs

ok i’ve just started up the 2 programs without any kit connected and here are the log files if the whole setup needs to be running then i’ll have to wait until i get another clear night as i don’t have the logs from last night


Those logs you posted do not show anything (nothing happened in SGP that would have initiated communication with PHD2). It would be better to get the logs from last night when you had the problem. The logs should still be present in the respective log folders. Look for yesterday’s date in the file names.


sometimes i must “stick” the st4 port again in the mount or guidingcamera to give an impulse to the mount/phd…try then new calibration with phd see if it moves…maybe u can try this…

Andy I don’t have the logs from last night it’s a long very dull story but I needed to clear out my files and the logs went as well

I shall try again next clear night

Thanks for help with everything so far

1 Like


OK, no problem, we’ll take a look when you have them.


1 Like

Just a little update. I managed to get a couple of hours clear sky again last week and everything worked perfectly. I didn’t change any settings so I’ve no idea what caused the issue the night before

All is good now :smiley:

A great bit of software

Sometimes a reboot fixes everything. Congrats!