Some astrobin images causes Plate Solve error

After successfully testing PlateSolve2 earlier, I tried to plate solve some images from inside Target Settings window and got the following error messages:

Please look at the Reference Data pointing to Astrobin ( ) and test it by clicking on “Solve” button. It didn’t matter which plate solver I was using, it showed same error message. This Astrobin image used to work on previous SGP versions. This Astrobin is still available and visible at the web site. Note that only a few Astrobin images gave me the same error messages. Most Astrobin images were fine.

Please let me know if works for you in SGP Target Settings window.

Using SGP, Windows 10 x64, HP Envy i5 laptop.


Admittedly, we should have a better error (and I will add one), but this is expected because astrobin did not successfully solve the image.

Wait… sorry. I’ll look into this some more. It looks plate solved actually… just somehow different than others. I’ll let you know what I find.

Thanks Ken for looking into this.



This one was a little odd. The solve was returning multiple plots for the single image. The first plot was for for the elephant trunk and was complete. The second plot was for the christmas tree nebula which was missing scale and caused our JSON parser to freak out. This has been corrected.

This image was not the only image to create an error message. There was one other Elephant Trunk image from Astrobin that also threw the error message. I am sure there are several others.

What’s strange is previous SGP versions (I think it was 2.4.1 or earlier) did not show the error message. I was planning on imaging Elephant Trunk Nebula last year and I created a new profile for this object and it was fine. Now a year later and latest SGP version is complaining. I can install previous SGP version on my older computer and see which version passed the Astrobin plate solve.


No need to do this. Probably won’t tell us anything all that interesting. Doesn’t really matter if it worked in the past if it doesn’t work now (SGPro might have regressed, the astrobin contract or endpoint logic might have changed, etc…). I have fixed it so that it does work… this, in the end, should be all that matters.