ST7 parallel and SGP?

Yes, I still have it. SBIG ST-7 with a CFW8.

Loaded the SBIG drivers, set it for parallel port support (LPT1, 0x378).

Opened SGP and told it that the camera is SBIG. Verified above settings. OK.

Clicked on the connect icon. I get a device not found error.

Now what?


You are probably the only user to have ever tried this in SGPro so we could have a bug here. We will need logs to troubleshoot. Please see instructions here:

I’m guessing you want me to use the upload feature of the reply dialog.

Here it is.sg_logfile_20160317210311.txt (18.6 KB)


Nothing obvious in the logs… I read through the SBIG manual and it indicated that it may be best to set the address to 0 as opposed to 378 or whatever (for whatever LPT port you are on)…

Using the SBIG driver app, please ensure that the camera is attached to LPT1, set the address to 0 and try again. If that fails, maybe cycle through the other LPT ports (also setting their addresses to 0)? If that fails, I can get you a version with more logging (we have no way to test this).

Tried setting each of the LPT ports to zero in the SGP dialog. Every time I got a “Invalid LPT address” error. Unable to comply with this recommendation.

I also tried to use each of the LPT ports specified in SGP. Same thing. Device not found.

P.S. I can send the log of this if you want, but looking at it, it looks the same as the previous one. Nothing deterministic in it.


No logs necessary. I will put some more logging in for LPT connections to see if we can figure out what’s going on.

  • Is CCDOPS able to connect OK?
  • Any other apps able to connect?
  • Does the SBIG software validate the port you think the camera is on?
  • Are you using any adapters?

Just trying to rule out hardware as an issue before we go straight to the software layer.


OK… I added more logging and I also for addresses to be set to 0. I will probably remove address specification all together… they seem to be only useful for OS’s we no longer support. This will be out in

Is CCDOps able to connect OK? NO

Any other apps able to connect? Yes. CCDOPS for DOS (Uggh)

Does the SBIG software validate the port you think the camera is on? Validate? I have the SBIGDriver set to allow LPT connections (32 bit). I have Version 4.01 Build 1 drivers installed as per the dialog in SBIGDrivers

Any adapters? No. Straight from the parallel port to the camera with a a cable.


Got CCDOps for windows and SGP to connect to the camera and cfw8.

Using the beta

Works in Windows XP (of which I had to do an install, hence my delay getting back to you). No, connections to the camera and cfw don’t work in Win7 or Win10.

Found the tidbit about the parallel driver only working up to Windows XP. Uggh.

Anyway, I’m plugging away at the software. Consider this connection issue closed (although I have another concern with SGP I’ll post in a different section on the forum after I do some research about the problem on my end).


OK. Well, if you can get this to work, we might have a fighting chance.