Stuck at "resuming the auto guider"

Hi all,

Looking for some help as I encoutered issue with guiding during sequence.

Here is the process: I calibrated PHD2, then generated a sequence from Framing and Mosaic Wizard, start the sequence, SGP runs plate solving and autocenter fine. Of course guiding was stopped during autocenter. Once framing is done the PHD2 re-started guiding with an auto-selected star, the PHD graph inside SGP also updates fine, but the status stuck at “resuming the auto guider” forever and finally reports error and I have to abort the sequence.

I will update a log once I have it.

Latest SGP version, PHD2 2.5.0dev9. I set the guider settling pixel from 0.2 pixel to 1 pixel, did not help. Also I believe due to the fact that the status reads “resuming the auto guider” and never get to “settling” there is a communication issue between SGP and PHD2?

Any ideas or if someone experiences similar issue, please help.

Thanks,
Yizhou

Hello Yizhou,

Please read through this post and we’ll see what we can find:

I just got the SGP log and PHD log out and attached here.

SGP log: https://www.dropbox.com/s/g785h8dxlnf886j/sg_logfile_20160102193006.txt?dl=0
PHD2 log: https://www.dropbox.com/s/xin68wvszzvxg8v/PHD2_DebugLog_2016-01-02_195535.txt?dl=0

It is super long as I end up turn off guiding in SGP and continue with the sequence. However I tried to reproduce the issue several times. I believe one occurs from around 19:57:55 after automatic center success. The log is probably a little messy but I appreciate if you can take a look.

Thanks,
Yizhou

I looked though your SGPro logs and see that a message was sent to PHD2 to start guiding. I then wnet and looked at the PHD2 logs. I got lost there after a few minutes though and might need someone like @Andy to assist (if he has time).

[2016/1/2 19:58:00] [DEBUG] [Sequence Thread] {“method”: “guide”, “params”: [{“pixels”: 0.3, “time”: 0, “timeout”: 300}, false ], “id”: 1003}

Exactly same issue for me.
It was impossible to begin the sequence. At the same point the sequence is waiting the Autoguider to resume and never occurs, so it finishes the sequence.

I also changed the settle error to 1 pixel instead of 0.5 with no success.

I use a neq6 and eqmod.
Software at the latest versions (25 for sgp and dev9 for Phd2).
I’ll try to upload the logs when I got connected to my remote observatory.

How long are you guys asking it to settle for? What are you seeing for error in PHD2? My guess is that you’re never getting your mount to settle, so SGP never stops. I’m running .25 SGP and dev9 as well.

I had a similar issue last night. Guiding was all over the place though, so I know that was the issue. I’ll be interested to see what solution comes up here so I can look out for a possible fix next time.

I don’t really remember the settling time… I was only changing the settling pixel criteria. PHD2 never show error. It was guiding fine on PHD2.

Is there another status called something like “settling the auto guider” after “resuming the auto guider”? If there is, I am stuck at “resuming”, making me think it might be a communication blockage and I am not getting to the “settling” part.

Hi Yizhou,

I just looked at the PHD2 Debug log. We see that your settling tolerance value was set to “0.3 pixels for 0 seconds”, then, at the end of the session it was changed to “0.2 pixels for 0 seconds”. These parameters tell PHD2 to consider guiding stable after a dither if the guide star distance from the lock position goes below 0.3 (0.2) pixels and stays below that threshold for > 0 seconds. Here are your actual guide offsets after each dither.

You can see that the guide offset never stays below your threshold of 0.3 (0.2) pixels (*).

You should probably use PHD2 Log Viewer to look at your PHD2 Guide Log and come up with more reasonable settling parameters. Based on the limited data above, I think something around 1.1 pixel for 8-10 seconds would be reasonable choices for your settling parameters.

I don’t see that in the PHD2 debug log that you posted. If you had closed and opened PHD2 it would create another debug log file, so maybe you need to upload the other debug log? The log file that you posted ends when phd2 was closed at 01:54:55.

Andy

(*) Even though the first frame after dither #4 was below the 0.2 pixel threshold, the settling criteria say that the offset must be below the threshold for more than 0 seconds, in other words at least two frames must be below the threshold. I just changed PHD2 to handle the special case of the dither settle time is being set to 0 so that phd2 will consider setting done if a single frame is below the threshold when settle time is 0 seconds. This is probably a moot point since you should be setting your settling time to something > 0 seconds to ensure that the guider is really settled. With the settling time set to zero a random star motion due to seeing or an overshoot guide correction could cause the offset to momentarily go below the threshold (like the first offset after dither #4) .

Hi Andy,

Thanks for your effort to look into this. I am sure I tried to play the settling pixel criteria and change it smaller and bigger. Not sure why it’s not reflected in the log. I don’t think I restart PHD or SGP so it should be on the same log file…

I think I didn’t pay too much attention to the settling time, and I guess leaving it at “0 second” could be the problem? I will also increase pixel criteria and try next time.

BTW I just want to know, as I mentioned previously, is there a SGP status “settling the auto guider” after “resuming the auto guider”? Just want to make sure it is the SGP/PHD setting problem, not communication problem between software.

Thanks,
Yizhou

I add my logs files.

PHD2_DebugLog_2015-12-30_222951.txt (424.1 KB)
PHD2_DebugLog_2015-12-30_201038 dropbox 1
PHD2_DebugLog_2015-12-30_225712 dropbox 2
PHD2_GuideLog_2015-12-30_201038.txt (98.0 KB)
PHD2_GuideLog_2015-12-30_222952.txt (9.3 KB)
PHD2_GuideLog_2015-12-30_225712.txt (368.2 KB)
sg_logfile_20151230222750.txt (766.6 KB)
sg_logfile_20151230201355.txt (502.6 KB)

Usually my guiding error is lees than 0.5 pixels. But hose days is greater. I don’t know why.
Maybe it depends on the object?

I thought it was a calibration problem and re-callibrated several times…

It’s very difficult to understand the logs files.
I’ve looked for some text strings and I found errors at:

> [30/12/2015 20:23:13] [DEBUG] [Sequence Thread] PHD2: Attempting to start guiding, waiting for PHD2 settle done message…
> [30/12/2015 20:24:12] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
> [30/12/2015 20:24:12] [DEBUG] [MF Update Thread] Performing serialize…
> [30/12/2015 20:28:13] [DEBUG] [Sequence Thread] PHD2 Failed to receive settle done message from PHD2 (timeout)
> [30/12/2015 20:28:13] [DEBUG] [Sequence Thread] PHD2 settle failed!

> [30/12/2015 21:31:02] [DEBUG] [Sequence Thread] PHD2: Attempting to start guiding, waiting for PHD2 settle done message…
> [30/12/2015 21:31:36] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
> [30/12/2015 21:31:36] [DEBUG] [MF Update Thread] Performing serialize…
> [30/12/2015 21:36:03] [DEBUG] [Sequence Thread] PHD2 Failed to receive settle done message from PHD2 (timeout)
> [30/12/2015 21:36:03] [DEBUG] [Sequence Thread] PHD2 settle failed!

> 30/12/2015 22:38:53] [DEBUG] [Sequence Thread] PHD2: Attempting to start guiding, waiting for PHD2 settle done message…
> [30/12/2015 22:38:54] [DEBUG] [PHD2 Listener Thread] PHD2: Settle done received: 1
> [30/12/2015 22:38:54] [DEBUG] [Sequence Thread] PHD2 settle failed!

> [30/12/2015 22:42:08] [DEBUG] [Sequence Thread] PHD2: Attempting to start guiding, waiting for PHD2 settle done message…
> [30/12/2015 22:43:23] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
> [30/12/2015 22:43:23] [DEBUG] [MF Update Thread] Performing serialize…
> [30/12/2015 22:47:08] [DEBUG] [Sequence Thread] PHD2 Failed to receive settle done message from PHD2 (timeout)
> [30/12/2015 22:47:08] [DEBUG] [Sequence Thread] PHD2 settle failed!

> [30/12/2015 23:02:14] [DEBUG] [Sequence Thread] PHD2: Attempting to start guiding, waiting for PHD2 settle done message…
> [30/12/2015 23:03:15] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
> [30/12/2015 23:03:15] [DEBUG] [MF Update Thread] Performing serialize…
> [30/12/2015 23:07:15] [DEBUG] [Sequence Thread] PHD2 Failed to receive settle done message from PHD2 (timeout)
> [30/12/2015 23:07:15] [DEBUG] [Sequence Thread] PHD2 settle failed!

Thanks,
Fernando

Were you calibrated or did you tell SGP to calibrate automatically? One thing I’ve noticed is that if I don’t watch PHD calibrate, it can get stuck in backlash compensation for whatever reason. My guess is that it was attempting to calibrate and wasn’t actually setting.

And to answer your question, yes, there is a ‘resuming auto guider’ and a ‘settling auto guider’.

Fernando, what were your seeing conditions like? Is your setup permanent? For instance, the other night I had ‘below average’ seeing on Clear Sky Chart and I couldn’t guide. The guide stars were bouncing around so much, I ended up with ‘streaks’ in my pictures. So, it could be your seeing conditions.

Or, as you said, calibration. I do calibration manually and let PHD2 adjust based on declination. Pick a star near 0 declination and calibrate on it. Look for issues such as backlash compensation.

The only values seen in the SGP and PHD2 log files are 0.3 and 0.2 pixels. Were you changing the setting in the Control Panel or in the Equipment Profile manager? The Control Panel contains the settings for the current sequence. The Equipment Profile Manager has settings that will apply to new sequences you create using “New Sequence with Profile”, but have no effect on the current sequence.

Yes, the settling distance and time were both problematic. The settling distance threshold should be set to a value somewhat larger than your ordinary total RMS guide error (in pixels). The settling time should be set to a value at least as long as the time it takes your mount to settle. You can use PHD2 Log Viewer to look at your PHD2 guide log to find your typical total RMS guide error pixels, and your typical settling time after a dither.

Andy

1 Like

I calibrated with PHD2 before the sequence. It calibrates fine and actually start guiding fine. Then I start sequence and SGP takes care of slew, autocenter, etc. During slew and autocenter the PHD2 will stop, and after autocenter is completed the PHD2 restart guiding fine. I think the problem is SGP can’t see PHD2 resumes.

Yizhou,

There is no evidence of that in the logs. PHD2 never settles to the tolerance level that you specified. Your settings require SGP to wait until guiding settles but it never does because the tolerance settings are too strict.

Andy

1 Like

Thanks Andy. I will definitely set larger pixel tolerance and longer settling time and try next time.

Can you please comment on the situation that SGP stuck on “resuming the auto guider” and never reach “settling auto guider”? To me it looks like the SGP is waiting for the PHD2 to resume guiding (which it actually already did) and never reaches to the settling stage. Am I understanding it wrong?

Thanks,
Yizhou

Ken or Jared would have to comment on the specifics of when SGP displays “resuming the auto guider” or “settling auto guider”.

I can only comment on the PHD2 debug log showing that guiding never settled. SGP waits for PHD2 to report that the guider has settled, but it never settles in your case (due to the overly strict parameters.)

Andy

The only time we ever display the status “Resuming the auto guider…” is after mount movement (typically target centering). This status will not change until a settle done event is received from PHD2. “Settling the auto guider” is only displayed prior to the start of a sequence frame.

Thanks Ken for the clarification. That means my problem is very likely on guider settling, and communication might be OK.

Yizhou

Hi folks,

I have a similar but different problem with “resuming autoguider” and phd2.

SGP opens PHD2 app fine, but then nothing happens, it does not attempt to connect to the equipment, pick a star, start guiding, etc.

if disable autoguider within SGP i can get PHD2 doing really nice guides, but i’d like to take advantage of the automation and dithering

events start around [1/31/2017 8:24:26 PM]
SGP log file https://www.dropbox.com/s/bc87fcikuw3pdg7/sg_logfile_20170131201423.txt?dl=0
phd2 log file https://www.dropbox.com/s/ec1f0ei0cdvhndx/PHD2_GuideLog_2017-01-31_202425.txt?dl=0

i’ve confirmed ‘enable server’ is checked on PHD2, it’s version 2.6.2dev8

I did adjust the settle settings from reading this thread to 2 pixel/ 0 sec wait time, but I don’t think it even gets to the settle stage

Thanks Brian