Trouble reading temperature from Optec TCF-s3i

Sorry if this has been discussed in this forum already. I have been using SGP for a while now and very happy with its capabilities. Recently, I connected to new Optec-s3i focuser and it seems to control focusing OK. SGP does not seem to be reading or displaying temperature from the temp probe on the focuser though.

I can disconnect, and startup Optec sw which reads the same focuser position as set in SGP, and does display the probe temperature reading.
Temperature probe disable is set to FALSE in settings (double negative).

I’m posting to request feedback from anybody who has experience with this and gotten it to work, or not.

thank you

Not sure. Please connect the focuser and send us the logs.

Hi Ken,
Thanks for the suggestion. I can see in an SGP log file, temperature numbers being read from the focuser. They just don’t seem to be displayed in the focuser control box. Is there any known issue with this?
Here are a few lines from the log:[4/16/2015 8:58:55 PM] [DEBUG] [Main Thread] Connecting ASCOM focuser…
[4/16/2015 8:58:56 PM] [DEBUG] [Camera Thread] QSI expose and download: 4106
[4/16/2015 8:58:56 PM] [DEBUG] [Main Thread] Focuser does not support halt
[4/16/2015 8:58:56 PM] [DEBUG] [Main Thread] Focuser supports temperature
[4/16/2015 8:58:56 PM] [DEBUG] [Main Thread] Current temperature reports: 14.3
[4/16/2015 8:58:56 PM] [DEBUG] [Main Thread] Focuser reports max steps as: 9999
[4/16/2015 8:58:57 PM] [DEBUG] [Main Thread] Tried to display solved stars, but list is null
[4/16/2015 8:58:57 PM] [DEBUG] [Camera Thread] ASCOM (QSI) camera: frame and focus…
[4/16/2015 8:58:57 PM] [DEBUG] [Camera Thread] ASCOM (QSI) Camera: setting gain to HIGH…
[4/16/2015 8:58:57 PM] [DEBUG] [Camera Thread] ASCOM (QSI) camera: setting high speed readout…
[4/16/2015 8:59:01 PM] [DEBUG] [Camera Thread] QSI expose and download: 4142


This is not a known issue (meaning no others have reported it). What OS are you using? What is your region set to?

I use a TCF-Si on some of my configurations and there is a bug (or design feature) with the driver in that if you connect or power up with the temp probe not installed or loose, then it will disable the temperature probe until it is reset using the stand alone controller app from Optec. You can reconnect/power down all you want and the temp will not show until reset from the app I talked to Jeff at Optec about this problem and he said it would be a simple fix and get it out in the next software update.

Frank Z…

Hi Ken,
Not sure what is meant by what region. I’m using windows7 pro 64 bit.

Hi Ken,

What specifically is the concern about region settings with windows 7? I’ll check them and respond.

Different regions use different number separators which can cause issues. Period vs comma.


Is there one format which is preferred for SGP?


Sorry my forum posting was not specific enough. The temperature reading from Optec focuser is not showing in the focus control “module”.

Related to the windows7 pro region settings question above, what specific setting are you looking for on my laptop?

Basically we are looking to understand if you have a region like English (US) or English (UK) set so we can check to make sure this is not a regional issue.

We may have a similar report from Spain, but based on your description, I am not 100% certain:

I’m in Southern California. My timezone is set to PDT. What more information can I provide you?

My focuser module display shows NA for temperature reading. So this does not look like the issue you mention below.

It is simple as that, display is always NA. I see the temperature probe readings in the log file for the focuser. It just is not being displayed from what I can tell.


I’ve been in contact with the Optec folks about this. It seems this is related to the Optec focuser not implementing the Halt command and apparently when Halt is called it results in issues inside of the driver.

You can try using POTH and disabling the HALT functionality. This should block the Halt command from getting to the driver, thus shielding the driver implementation from this.

Then connect SGP to the POTH focuser.

This isn’t likely something we’re going to change in SGP. We’re following the ASCOM recommendation about testing for Halt by sending the halt command and catching an error if it fails. Changing the behavior in SGP would affect other focusers that don’t behave in this manner. Unfortunately this seems to put the Optec driver into a bad state. It was mentioned that they’re going to be upgrading their driver somewhat soon but I’m not sure if they’ll be changing this behavior or not.

Let me know if that works.


I tried using POTH hub and disabling Can Halt.
The focuser does connect, but the display is exactly the same as in using ASCOM driver.Jeff, you said in email when you look in the control panel with focuser connected, you see temperature displayed.
So, I went back to OPTEC ASCOM driver and unchecked the Use TEMPer device for temperature input. Now there is a temperature reading.

I thought there was a problem Can Halt which inhibited temperature probe from being read?

I’m starting to think we are not all talking about the same issue.
I have version of SGP running. Now the temp probe appears to be working.

Thanks Steve,

I’m not yet sure why the temp probe is being disabled and from which program. I need to plan a little more time for testing on our end.

Jared, do you need anything from us?

Very best,



Jeff – Optec Sales & Support
199 Smith Street - Lowell, Michigan 49331 - U.S.A.
Toll-free: 888-488-0381 - Office: 616-897-9351 - Fax: 616-897-8229