Trouble with ASCOM Telescope Driver for TheSkyX

Hi: I have a win 10 PC, SGPro version, TheSkyX Pro version 10.5.0 build 12289, Paramount MX+ mount.
I have ASCOM 6, I have the ASCOM2XDriver installed.

Within SGPro, I have set telescope to ASCOM telescope driver for the skyx. I have mount on, TheSkyX running, I open SGPro, but when I click to connect telescope I’m receiving a message saying “TheSkyX was selected, but it does not appear to be installed or configured for scripting”. I checked in TheSkyX and I have the TCP server listening, port 3040.

I can’t get this to work. This all had worked on my Win 7 machine for last several years

any suggestions?


I’m not sure exactly what the problem is but you want to make sure you are running the latest version of ASCOM (6.4) and have updated Windows 10 with all the latest updates. There was a Windows 10 update a year or two ago that broke ASCOM.


Hi: I have latest ASCOM 6.4 and Win 10 machine automatically updates (unfortunately) so these are up to date. I tried to reload ASCOM 2x Mount adapter but still not working with SGPro …it seems it’s not working for PHD2 either

this all worked seamlessly on WIN 7 machine for last several years


Does TheSkyX on windows 10 control the mount as it should?

What are your settings in the ASCOM driver?

In my TSX, the TCP server is not running at all and everything works fine.


Hi: yes TSX connects to mount, haven’t tried it in the field, but in meantime Tom on the TSX site suggested right clicking TSX icon and choosing “run as administrator”, and that worked for SGPro and it fixed same issue with PHD2. Not sure why I would need to do that but it helped!!


At least it was an easy fix. It’s probably a Windows 10 security issue that blocks access to certain controls for users, even if logged in as an administrator. It’s been so long since I went to Windows 10 that I forgot about that. Glad you got it fixed.


It is more subtle than that. I have the same setup. You can run all apps as administrator, or not, but not a mixture. It has been like that for several years. I used to run as admin by default but for a reason I cannot recall, turned it off on all my apps.

I just looked at my TSX shortcut, it’s not set to run as administrator and everything runs fine.


Whenever you update TheSkyX, you need to start it in administrator mode with each program that it runs with. That registers them with each other after which you can run them all as normal mode or in administrator mode but you can’t mix the two modes. I’ve also had the same issue.