Troubles with Moonlite Rotator

Link to Log:

Using version

I’ve been busy with my day job for so long, I’ve almost forgotten what the sky looks like at night. Anyway, I got out under clear skies last night, and tried to start imaging M31. I’m trying to create a mosaic of that, since it’s so big, and therefore the rotation of the image is an issue. Once I got everything all set up, I started the sequence, but it kept failing, (and I must have tried a dozen times), on the image rotation step. SGP seemed to know that I have a MoonLite Rotator, but it never managed to make the rotator move as much as a single degree. The error message was just a generic failure on step three of the plate solve. I used to plate solving delay to try rotating the camera, myself, using MoonLite’s hand controller, and I eventually managed to get it to within the 5 degree tolerance that is set.

Can you tell what I have set up incorrectly? The MoonLite focuser has worked in the past, though never to rotator. Last night I could not get to the focusing step. I was able to use MoonLite’s software, separately, to control focus and rotation, during my set up of the scope, so there does not appear to be a comm problem between the computer and the MoonLite device. You can see the first error at about 10:41.

(The full log is available on the link, above.)

[9/4/2016 10:41:33 PM] [DEBUG] [Telescope Thread] ASCOM Rotator: Error in Move(abs) : MoveAbsolute set - ‘18332.22’ is an invalid value. The valid range is: 0 to 360. (System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.Runtime.InteropServices.COMException: MoveAbsolute set - ‘18332.22’ is an invalid value. The valid range is: 0 to 360.
— End of inner exception stack trace —

18332 is the number that MoonLite’s hand controller was showing, so it seems clear that the device could talk to SGP, but, based on my reading of the logs, it seems that they could not agree on whether they were discussing degrees of rotation, or steps.

The log is full of these, since I kept manually rotation it until I got it roughly into line with the reference image.

I am willing to accept that I haven’t got SGP configured properly, but if that’s the case, I would sure appreciate a little advice on getting it set up properly.

(Even once I got the rotation handled, manually, SGP failed to ever get going, because even though I thought I had PHD2 running and working properly, SGP demanded a recalibration, which failed. It’d be nice, I think, if SGP would display that it was waiting on PHD2… since I didn’t figure that problem out for a rather long time, and I could not see any indication, until SGP gave up, that that was what was going on.)



The ASCOM driver should be thinking of rotator positions in degrees, not rotator steps so it’s a bit of a mystery - and I wrote it!

Maybe there’s some problem with what is reported, the rotator hardware has to be addressed in terms of steps while ASCOM uses degrees. Perhaps there’s some problem with this conversion, especially if the steps go outside the range that is expected to be converted to 0 to 360 degrees.

What this waffling is leading up to is can you collect a driver log for the same period as a SGP log that shows the problem. There should be a Trace On checkbox on the driver setup and the log will be in the My Documents / ASCOM Logs folder.
A driver log would be useful anyway, it will give chapter and verse about the driver state.

I’ll look at it but it’s going to take a day or two before I will have the spare capacity and a driver log would help to show what’s going on from the driver’s perspective.

Chris R

Thank you, Chris. Naturally, I was not running logging on the ASCOM drivers last night. So, I’ll see if I can figure out how to turn that on… (Can you explain where one might find that bit to twiddle?) And then I’ll set up just in the back yard to see if I can get it to throw the error again… next clear night.

(Is there a global ASCOM Trace On switch? Or is it specific to each piece of kit. I’m not aware of where, specifically the MoonLite’s driver lives, or how to bring up a User Interface for it. SGP seems to know, because that is one of the things it connects to when it sets itself up… so I guess it must be on here, somewhere.)

Obviously, no one is being injured by this, no lives are in danger… I’ll get you some logs ASAP, (won’t be tonight; all clouds here), and after that you may look at them at your convenience.

Be well,


If you click the setting button for the focuser (wrench by the connect). That should bring up the ascom settings that likely has logging options in it. Not by my obs machine so can’t verify that for Moonlite at the moment but that’s almost certainly where the logging option lives.


Excellent, thank you.

That’s correct, the driver setup dialog is the only place that an ASCOM driver can have UI.

A separate log file may be useful because it gives chapter and verse about things such as versions an the rotator limits.

Chris R


For what it’s worth, step 2 of the centering process performs an “internal sync” of rotator PA to sky angle. This statement from the logs is a little confusing to me:

[9/4/2016 10:40:56 PM] [DEBUG] [Telescope Thread] ASCOM Rotator: Sync complete. Camera angle is 31.85; Reported pos rotator position: 18415.08

The angle 31.85 is the sky angle (east of north) and the second number is supposed to be the rotator’s PA. It is obtained from ASCOM.DriverAccess.Rotator.Position (directly). Seems odd and I’m not sure where to start without the device logs. @karlwlewis providing the device logs will make tracking this issue much easier.


I’m not sure that I have what’s needed. I setup in my backyard, (too much light, too many trees, WAY too many mosquitos, and severe thunderstorms headed this way), and sort of rushed through setting up the scope. The error I got this time was a failure to sync or rotate, I’m not sure that’s the same as last time. But I do have a trace from the MoonLite driver, so there’s that.

SGP Log:

MoonLite Log:

As I say, this evening’s attempt may be suffering from some other error, so don’t kill yourselves on it. I mean, I can see some of the same stuff, but I think it had some kind of comm error, this time.


Thanks for the logs.

The rotator log only shows a connect at 21:28:34 to 37 and nothing else. Is there a later log? I can see mention of reading and syncing the rotator a lot later in the SGP log, up to 9:46:07 PM.

The communication errors seem to be to do with the telescope, not the rotator.

I’ll try to have a look and see if I can see what may be causing the strange position reports. It may take a while, I haven’t needed to look at this code for ages and Ron is pushing for a new driver for his new focuser/rotator unit.


:confounded: Yes… it was a different error. I’ll wait out the rain and try again… LIkely, I need to be a little more diligent about the scope’s alignment… I was thinking SGP would just cope, but, I was mistaken. (That’s not a complaint about SGP, just commentary on my own ignorance.) I won’t try to race a thunderstorm, next time.

I will post more logs when I’ve gotten good data.

Sorry for the trouble; thanks for looking, anyway.


So… it is a lovely clear night, with cool temperatures, and I had some mosquito repellent.

It occurred to me… maybe the problem with the rotator was just the number of steps that it had taken… it was showing some 18,000. It’s a rotator, right, so, it could show a million, it just keeps goin’ round and round. So I ran it down to zero, and set up to try my sequence again. This time I spent some time to get the scope aligned, (not polar aligned, which I just can’t do here in my back yard because the trees block my view of the celestial horizon), just a regular two star alignment with a calibration star or two, maybe.

I had high hopes that setting the rotator’s steps back down to a low number would fix the issue I’d been having. Alas, it did not. On the bright side, however, I think I have all the logs that a developer could want.

The SGP Log shows the proper error at, for example:

[9/10/2016 9:11:39 PM] [DEBUG] [Telescope Thread] ASCOM Rotator: Error in Move(abs) : MoveAbsolute set - ‘-134298.2’ is an invalid value. The valid range is: 0 to 360. (System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.Runtime.InteropServices.COMException: MoveAbsolute set - ‘-134298.2’ is an invalid value. The valid range is: 0 to 360.

The MoonLite Log shows no error that I noticed after a breif inspection, but I’m not an ASCOM Developer…

I hope this helps.

Clear Skies,


1 Like

From what I see you have a MoonLite DRO box with a focuser and rotator connected. The focuser is connected to Motor 1 and the step reading on the box is 7679 and the rotator is connected to motor 2 and the step reading is 0000. Is that correct?

Are the focuser and rotator set this way in the MoonLite driver setup? Focuser on port 1 and rotator on port 2.

The reason I ask is that if I take the rotator position in steps and the angle reported, then apply the conversion from steps to angle in reverse I get a step size of 4.14 which is the conversion between steps and microns for a focuser. For a rotator the conversion should be more like 94 to 100 steps per degree. If that was applied then the rotation value would be sensible.

It will be worth checking that the driver setup has the rotator device set as a rotator and that the connections to the motors are correct.

Hope that helps,


The driver appears to me, when I look at the setup, to agree with me with regard to which function is on which motor. And, yes, last night motor 1, the focuser, read 7679, (or something close to that), while I had set motor 2, the rotator, down to zero.

The Auto Focus routine seems to have no troubles moving motor 1, and changing focus; that’s worked more-or-less properly for quite some time, now. And, it worked properly last night; it went through an auto-focus routine. (Though I did not get a nice, pretty V-Curve.)

(I have big marks on my cables, so that I get them connected to the right places, and I always double check that, by verifying that the hand controller moves the expected component.)

Are you suggesting that I should set it up the other way 'round, both physically and in the software? (I don’t recall having seen anything that said hook one or the other to a particular port, so I had set it up arbitrarily, with the focuser on port 1. I’m willing to have been wrong.) From my point of view, it seems that SGP is doing something odd… but I recognize that others are not having this difficulty, so, having put the motors on the wrong ports makes a kind of sense, albeit horridly embarrassing.

It may be clear again tonight, so I’ll play with this some today and try again tonight.

Again, thanks for looking.


See? This is the risk with posting about problems on a public forum… you can get your problems solved, perhaps, but at the considerable risk of being exposed as a fool… I do try hard not to make absolute statements, since those tend to be bitter and tough to chew, later, if I have to eat them.

1 Like

I think we’ve all been proven wrong before. The pain goes away when you take the next sweet picture :blush:

1 Like

If the focuser is reporting correctly and moving correctly then it looks as if it is connected correctly and that means that the rotator is also physically connected correctly.

Maybe the rotator port has been set up as a focuser, I’m not sure how that could happen but it would account for the very large negative number for the position.

Try going through the Rotator setup with neither focuser or rotator connected. Make sure that port 2 is set as a rotator of the correct size. Check the set position checkbox with the position set to 0.
Then connect the rotator and use the Control Panel - Other tab to check this. Zero degrees should correspond to a step value of 32767. You should be able to try this without having to wait for a clear, dark, sky.

There’s nothing embarrassing or foolish about having a problem and asking for help. What’s foolish is having a problem and pretending it’s OK or hoping for the best.

My other hobby is flying and in that being in denial over a problem can be lethal.


So… looking at the focuser set up through SGP’s Equipment Profile Manager… I see this:

Motor two is listed as both focuser and rotator. That’s a little weird.

I can check the set position box, but it doesn’t appear to be persistent. Nor does setting both the motor two entries to “Rotator.”

MoonLite’s documentation, such as it is, suggests that for the 2.5 inch rotator the scale is 115.833 steps… how that relates to 30 steps/degree, I’m not sure.

Using MoonLite’s non-ASCOM driver, I got the thing set to 0 degrees of rotation, and indeed, the step position for that is just about 32K, 32764.

Oddly, the Control Panel “Other” Tab shows the Rotator, “Not Connected” even though, it is connected:

So, I’ve fiddled with the settings, and I have the controller set to thinking that the device is now at zero, so maybe that will get it, and me, past this confusion.

I really do appreciate your time, patience and help.


Space travel is safe enough… you know, as long as you do it on a planet… I’ve been zooming around this star for more than half a century… seems as safe as houses. In any case, a little astrophotography along the way does not seem to appreciably add to the risks.

1 Like

Karl, you can test all of this during the day right? minus the auto solving part?

Yes… and I’ve done that. I there more you think I should be checking?

(I’ve just set up the 'scope outdoors, again, before dark, (it’s so much easier to see what I’m doing), now, I’m just waiting for nightfall.)


Awesome, I’m glad you have it working manually at least. Post when you get through the first one!

It looks to me as if you haven’t set up the rotator. The setup image you post is for the focuser, it says “MoonLite Focuser Setup” at the top. You also need to set up the rotator.

Select the rotator option in the SGP sequence window and click on the icon with the spanner. You should see something like this:

Note that the setup title is for the Rotator, that Motor 2 is selected as a rotator and that the steps per degree is 94.
Click on OK, then click on the connect button. This should cause the rotator to work.

Hope that does it.