"Unable to download image" error message

This happened a couple times last night, and thinking back I know I’ve seen it now and then in the last few sessions. This message pops up, and that image is lost. I’m not sure whether the message is from SGP or ASCOM (sorry, I haven’t been alert enough to do a screen grab, but I will be in the future). The log from last night is here:


This happened on my first light frame, about 12:40, and on my first flat, at 4:57. The log shows that the camera at both points had been reporting an error message - unable to get the cooler temp. This is SGP 2.3.5. Any idea what’s happening here? After the first light frame, I got the camera running again - I think I disconnected and reconnected it - and captured five more lights, and then 250 bias frames, before it ran into the problem again.

I don’t know if this is related, but at the beginning of the session, SGP had frozen on me while I was doing frame and focus images. I think it didn’t like the fact that I changed the exposure duration while a frame was downloading, and it got stuck in the download process. I tried disconnecting the camera, but it wouldn’t disconnect, so I had to exit and restart SGP. I’ve run into that problem several times before, so that I try to be more careful when changing exposure durations.


That’s interesting. We can take a look, but changing exposure time during camera operation should be a completely benign operation.

Not at all sure it pertains to Kevin’s problem but I had several instances of images failing to download. In my case, it was traceable to a cheap USB hub. A better hub solved the problem.

Nothing to do with changing exposure times though . . .