Unknown issue with SGP beta

Just downloads and installed the new beta I really appreciate the dark theme in particular but found the beta to be very “laggy” and “crashy”. Seemed very slow to respond and several timed crashed randomly. I’ve reverted to the previous version I had ( as it’s worked perfectly fine for me so far with many nights of flawless unattended imaging.
No idea if what’s happening is because of something on my end or if it’s an SGP issue. Just thought I would put in up here in case.
I’ve attached some logs of my playing around to get familiar with the new look.

The first log shows a crash. Can you tell me what you were doing (how you were interacting with SGPro) when it occurred?

Also, can you summarize the specs of the machine you’re running SGPro on? Processor, RAM specifically.

Here’s a screen shot of my laptop’s specifications.
When the crashes were occurring, I was interacting with the sequence generator window. Basically playing with targets and target events.
I saw another log file from when I was playing around with the new beta.

Hope this helps somewhat! Haven’t had a problem with since installing it so will stick with that for now! Also no equipment was connected when I was playing around to get familiar with the new beta.

Would you mind sending the Narrowband Targets.sgf sequence? It looks like SGPro is crashing while trying to load it.

No problem. Here’s a link.
I have done a couple nights of imaging since and have been re-saved a few times since I reverted to
If the problem can be fixed by just rebuilding my sequences with the new beta then I can do that.

Hey mate did you happen to find out what was going on? I noticed a few more beta releases since.

No, I was unable to trace this issue as that sequence opens with no issue here. There is a decent chance that the issue you were seeing has been corrected as a result of other beta changes. I am going to release beta in a couple hours. I would recommend giving that a shot (I suspect anything prior to the new 715 beta will yield the same result).

No worries mate!

I hope to have this fixed in beta 715 available in a few minutes.

1 Like