userProfile not updated in sequence file

Hi SGP Team,

When I try to run sequences, the message “SGP cannot determine if slew requests will … etc…”
They was a previous issue in the forum about this message, so I investigate around user profile.
I appears than userProfile entry is always set to “null” in sequence file although I set user profile in GUI.
I’ve tried several things such create sequence and profiles from scratch.

Due to bad weather, I hadn’t used SGP for a long time and I don’t remember the latest functional version.

Link to Logs
With logs I added sequence file, user profile, equipment profile

Useful Info
OS: Win 10 x64


I downloaded your sequence and loaded it (did not modify anything)… and your user profile loaded immediately and no warning was issued on sequence start. Are you actually looking at the JSON?


The field “userProfile” is deprecated and no longer used. The ID below it is the only one of importance.

Well, very strange that you success to run sequence.
I 've fully uninstalled (with Revo Uninstaller), deleted all SGP directories and reinstall SGP.
I’ve created new sequence with an allways visible target (Polaris) and LRGB default profile and warning message still there when I run sequence
Attached log file, equipment and user profiles and sequence

Maybe what we are seeing here is a regional issue. What language and reason do you have Windows set to?

I’m living in France and of course Windows 10 is also in French.


I noticed a similar issue a few betas ago - in which the user profile kept on going back to null.

This seems to have been fixed in the last handful. Have you set your user profile as ‘default’?

Yes, user profile is set as " default"

I installed a US version of Windows 10 on a VirtualBox. The only “regionalization” I do is French keykoard and time zone
Then I only installed Ascom and SGP. I created a sequence with the LRGB profile. Only one user profile as well
The problem is still there, so it’s not a problem of regionalization.
Here, logs, profiles and sequence:

Well, that’s definitely helpful information. I am unable to reproduce this issue. There is one issue that is present where the user profile selector will go back to “None” any time the “User Profile Manager” is closed. Is that maybe what you are seeing? When you open the sequence and don’t do anything at all, is the user profile showing properly in the dropdown?

yes, I confirm that user profile is correctly set when sequence is opened

maybe it’s a stupid remark, but did you reset the “Don’t ask again” responses?

Oh, ok. Thx. I did find this issue buried deep in a failure to properly detect a valid latitude all of the time. It will be out in

1 Like

Good news,