Weird problem with new Canon 6D and SGP

Hm, well if it’s both the CR2 and the FITs then it’s not happening inside of SGP as the CR2 is raw and unedited from the camera. I wonder if this is a setting that can be changed inside of the 6D? Do you see this when shooting with the camera normally in CR2? Maybe a setting or possibly a defect with the camera?

Jared

Hi Jared,
When I shoot daylight images the border is not visible in CR2. I am imaging now, so I just did an image with Nebulosity, and there is no black border. It is visible in SGP taken CR2, but it is more grey than black. But it is not visible in CR2 that go from the camera to Photoshop or DPP. It only seems to appear with images taken using SGP. And it sure is messing with the histogram. :slight_smile: And I assume that is what is stopping me from being able to get a reasonable image after stacking good subs.
Dean

Some higher end Canon cameras have border pixels on the CCD. They are use primarily for calibration… some have bias and other are uncharged for baseline readings…

We use DCRAW to read your sensor and it reads ALL of the pixels. I’ll look to see if DCRAW has an option to remove these calibration borders from RAW images (though quick investigation did not reveal anything that would do this without performing a white balance). You can look at one of your CR2s with exiftool to see if you have properties “sensorLeftBorder” and “sensorTopBorder” (or similar).

Hi Ken,
I see exiftool runs from a command prompt, and I am not computer savvy enough to know what the hell I am doing in that environment. If you would be willing to take a peak, here is a link to a CR2 image taken with SGP a few nights ago. If I open the image in either Photoshop or Digital Photo Professional, there is no border and data right to the edge. But if I open it with Gimp or Nebulosity, it has the border.
Canon 6D sample images

| |
| | | | | | | |
| Canon 6D sample imagesShared with Dropbox |
| |
| View on www.dropbox.com | Preview by Yahoo |
| |
| |

Dean

Hi Guys,
I can confirm they I also get a similar border to that described with my 6D and it is fine in Nebulosity 4.
The sensor resolution for the 6D is given as 5505 x 3670.
If I place the cursor as close as possible to the RH Lower corner it reads X:5550 Y: 3692.41
Placing the cursor on the top LH part of the image (i.e. inside the border) it shows X:1414 Y:37.25.
In the top left corner of the screen gives X:0 Y:0
The figurers are not exact as it is difficult to place the curser exactly at the right point.
Don’t know if this is of any help?
Cheers,
Bob.

Hi Bob,
Thanks for the input. Do you have the same border on just two sides in Nebulosity, likeI do? Because Nebulosity 3 can’t process the image properly with that border present.

Can I ask where you got the dimension of 5505x3670? Because in the Canon manual it says that should be 5568x3708. That is what I have entered in SGP under camera in control panel. And the difference between those numbers is enough to give me the borders, with the border on the side about twice as wide as on the top, just as the numbers would indicate.

Ken it couldn’t be so easy as changing those resolution numbers in control panel, could it?

Dean
’We must respect the other fellow’s religion, but only in the sense and to the extent that we respect his theory that his wife is beautiful and his children smart.’ H. L. Mencken

So… feel free to test this if you’d like (we don’t have a spare 6D hanging around). No super technical skills required… just download this:

https://dl.dropboxusercontent.com/u/24325878/dcraw.zip

Unzip it and replace the existing dcraw.exe in your “Program Files (x86)/Sequence Generator” folder. I have no clue if it will assist with this issue, but it is a newer version of dcraw. We already use an option in dcraw that is supposed to get rid of these overscan areas ("-D"), but it seems ineffective on the 6D (at least the version of dcraw we distribute).

Dude…when do you sleep?

I am once again in awe at your level of customer support. The new dcraw file did the trick, the black border is gone. Very pleased…thank you!

Dean

Thanks… sound like we should distribute the newer version starting next beta release.

Hi Dean,
The pixel area came from a review of the 6D and supposed to be the effective area but it looks like that is incorrect. Sorry.

I am saving in both RAW and FIT mode.
If I open the CR2 and FIT files in Neb4 I see different results for the same capture.
The FIT file shows the border along the top and LH side and it gives an image size of 5568 x 3708
The CR2 files does not show the border and gives an image size of 5496 x 3670.

If I capture using Neb4 I there is no border and the image size is 5496 x 3670.
If I open a CR2 in Nebulosity taken by the camera I get 5496 x 3670.

So it looks like the conversion in to fits format that there is an issue.

Cheers,
Bob

P.S. According to the Canon website the image for RAW is given as 5472 x 3648 and this matches with a downloaded manual.
So is your 5568 x 3708 total number of pixels rather than effective number?

Hi Rob,

I just checked the 6D manual that I had downloaded in pdf, and it says 5472 x 3648 “recorded” pixels. Everyone sure does measure it differently. Even 2 different Canon manuals. Happy to say that it is now a non - issue with the fix from Ken. Black border is gone and I am ready for some dark clear skies. Thanks again for your help.

Dean

Hi Dean & Ken,
Works for me to. Many thanks for great response.
Bob.

Okay this is bizarre…the black borders are back. Trying to image now and there they are again. WTF?

Dean

I don’t understand this at all. The black borders are truly back. I checked and I am using the latest version of SGP - 2.4.2.9. I tried opening SGP from two different icons in case somehow one was connected to an older version. Both open 2.4.2.9.
In desperation, I even removed the new cdraw file from SGP, and then put it back. No change.

When I first tried the new cdraw a few days ago, I tried it both with frame and focus, and a main image. Neither had the black borders. Now both do again. How in the world is this possible?

Dean

I do not know. Did you re-install SGPro, repair it? Are you managing different installs of SGPro? If you are using multiple installs of SGPro make sure to check the about box to ensure you are using the correct one. You can post a CR2 on dropbox and I can run dcraw here too to see what it does (best I can do w/o the camera).

One copy of SGP only, and I check the version number as it opens. No repair other than replacing the cdraw file Here is a fresh sub, just prepared. :slight_smile:

Dean

Hi Guys,
I have just set everything up and taken another quick run through the three file saving variations and none show any borders in SGP or Nebulosity and all are given as 5496 x 3670.
So still working OK here with the new cdraw file.
Cheers,
Bob.

It has been awhile since I worked with my Canon DSLR, but in short, saving the images as FITS includes the overscan, whereas CR2 does not. (The overscan may very well be there in the CR2 file also but perhaps software that reads the CR2, like PS, reads overscan info from the metadata and automatically crops it, I’m not sure.)

It shouldn’t affect the final outcome as long as you’re consistent. Awhile back, the setting to save the images as FITS was changed on my machine for whatever reason, so at the time all my lights were FITS and calibration were CR2 as they were taken at another time. PixInsight will complain that the geometry doesn’t match, but this is fixed by specifying the overscan settings in PixInsight. This allowed me to calibrate my FITS with my CR2 files without reshooting calibration frames.

At any rate, as long as you are consistent with acquisition, it shouldn’t affect the usability of the images but IIRC, it can throw off statistics. For that reason, I stick with CR2 when using my DSLR – it’s just easier.

I should have added the previous test was with version 2.4.2.8.

I have just upgraded to 2.4.2.9 and the borders returned. Updated cdraw with the file previously given and all now OK again. No borders.
Hope this helps?
Cheers,
Bob

The new dcraw files will not be distributed until 2.4.2.10.