What Settings for a Maxdome Controlled Roll-Off Roof?

I have solved my guide/flip issues by using the Generic ASCOM hub but the roof control is being a bit of a problem.

First I tried selecting POTH in SGP - dome options (profile manager):

The POTH popup control allowed manual open and close with that but did not seem to respond to SGP commands and, in fact, did not show as connected in SGP.

I have tried both selection of POTH directly in SGP as well as selecting Generic Hub under “dome” in SGP and then POTH under Generic Hub in it’s dialog.

The roof is controlled by a Maxdome board so I tried selecting Maxdome directly in SGP dome options (profile manager) but that also does not work.

In each case the control panel "other " tab shows all the options greyed out except for “slave settings”.



I have a fosters controller, so I’ll tell you what I do and maybe that will help you. Under the Dome/Roof section, I select ‘Foster Systems AstroMC Roof Controller’ which is the name of the ASCOM driver for my roof controller. In addition, you must have a mount connected in order to get the menu options to work.

Under the Equipment Control Panel, you need to go to the ‘Other’ tab. Make sure you select the checkbox ‘Slave to Mount’. This will make SGP coordinate the movement of your roof when it decides it’s ready to move your mount around. Under the ‘Slave Settings’ option, select ‘Roll Off Roof’. From there, it’s personal preference but I have all of the checkboxes selected. This will cause it to open/close the roof when you park your mount.

They’re saying in 2.4 they’ll give us access to weather station support too. if you have one.

Hope that helps! Edited for this system’s silly use of the indent key…

Yes, I did basically the same thing except using Maxdome II (my ASCOM controller) and it did not work.

If you can try connecting, opening and closing the dome and posting the
full log we can take a look.


Jared Wellman
Co-Owner and Developer
Main Sequence Software

Arghh! I am an idiot!

I would like to think it was just a 2:30 AM idiot.

I had not noticed the arrow to spin open the Flat Box/Rotator/Observatory Connections. It is now connecting with just Maxdome selected so I suspect it will work. I will give it a full on test tonite.

Speaking of that dialog set, I do have a question about how to activate a home made flaxbox. I will post that to a new thread.

Glad it’s working.