2.4 and weather station

For some reason my weather station doesn’t show up under the weather station tab, but does show up under the ‘dome/roof’ tab. Any ideas on how to fix that?

I went to the profile explorer, and the AstroAlert shows up as a Weather driver and not a SafetyMonitor.Driver.


What does it look like in the ASCOM Profile Explorer? It will need to be registered as a SafetyMonitor.

For testing I used the Boltwood Safety Monitor that Chris R. made. I assume this is the same thing you’re using since you’ll be using it with a Boltwood sensor?



I manually copied the info from the ASCOM Profile Explorer ‘weather’ tab to the SafetyMonitor tab. It allowed me to connect at that point.

Yes, it’s the same thing as a Boltwood 2.

Is there a way to see if it works? I set the station to report ‘safe’/‘unsafe’.

Notifications work great btw.

It’s been a while since I implemented that. If I recall it is currently only active when a sequence is running. So you’d need to start up a sequence to see it take the “unsafe” action. It will then abort the sequence and run all of the “End of Sequence” options that you have set (parking mount and closing obs…etc)

This may change at some point but the thought is that if you’re not running a sequence then SGP should be completely at rest and your gear should be in some sort of protected state already.


Yea, I guess I was hoping to avoid ‘testing’ it by running a sequence. It’d be to have a stoplight in the lower tool bar with everything else that shows you ‘green’ for safe and ‘red’ for unsafe.

One question, can I run recovery mode and use the weather station? I just don’t want recovery mode to interfere with it shutting if it gets an unsafe signal.

I’ve tried the weather monitor using my Boltwood monitor.
If the mount is set to park the mount at the end of the sequence then if I start the monitor in an unsafe state then after 30 seconds it parks the scope but not the dome. This may be because the dome was not slaved to the mount and so the dome slave setting of park the dome and close the shutter when the mount is parked was not done. It would seem better to do this regardless of the slaved state.

I disconnected from the safety monitor and tried to reconnect and got this error as soon as I tried to connect:

Connection Error

Error connecting to ASCOM Boltwood OK to Image!
Index was out of range. Must be non-negative and less than the size of the collection.

Parameter name: index


This doesn’t seem to be coming from the ASCOM driver, there’s no evidence in the ASCOM logs that any attempt was made to start the safety monitor.


This is correct. The weather station only runs the “End of Sequence” options. If your obs is not slaved to your mount then it will not close the obs. The assumption is that if you’re not slaved then you don’t want your observatory to follow your mount (for whatever reason). It’s dangerous for us to make that assumption for you.

I’ll look into that error message.


1 Like

Here is a picture of it.

It was repeatable as he described.