2.5.0.x blind solve minor issue

Hi Jared and Ken,

This is mostly a cosmetic issue but I imagine it could cause some confusion for your users.

When I blind solve an image using local astrometry.net, SGP shows this:

I think it should say “PlateSolve courtesy of Astrometry.net” with the Astrometry.net logo. Otherwise it makes me think I do not have my blind solver setup correctly.


Thx… this is true. It is a bug and comes from the primary solver still being set to PS2. I’ll look into how to address this.

For SGP beta, the blind solve failover using local astrometry.net server is still not working. I currently have PlateSolve2 as the primary and the endpoint setting to for blind solve failover. Failover blind solves and explicit blind solves are going over the internet to the remote astrometry.net website. It was my understanding that if I point the blind solve failover setting to the local astrometry.net server it would use that for blind solves??


It should be working but setup is a little non-intuitive at the moment.

  • Select Astrometry.net from the plate solve drop down and open the settings
  • Set your URL as above and save.
  • Go back to the plate solve tab and select PlateSolve2 as your primary solver
  • Be sure to enable the failover option.

If you still have issues please let us know.

In the future we’ll be moving the failover settings to a different area that is more clear.


In, you can do what Jared said, but you can also just set the address using the new “Settings” button next to the “blind failover option” in the control panel or profile manager.

Blind solves will not go to my local ANSVR using either setup procedure. When connected to the internet, blind solve goes to astronomy.net. When disconnected from the internet, blind solve produces the error “Failed to plate solve image”. All the settings are correct, it just doesn’t work! I know the local ANSVR is setup correctly because when I select “Settings” in the blind solve failover settings the local ANSVR config webpage appears. Also I can see the local ANSVR was accessed in the Watch ANSVR Log.

Just so I’m understanding SGPs capabilities, if I enter the local ANSVR endpoint in the blind solve failover settings, select “Use blind solve failover”, then select “Blind Solve” on an image shouldn’t blind solve be directed to the local ANSVR?

Mel fixes several issues where settings were not propagated correctly to the blind solver.

Blind solve is working now. Thanks!